Zen.Barcode Namespace

Zen Barcode Framework
Zen.Barcode Namespace
Namespaces ► Zen.Barcode
Barcode Framework Version: v2.0.3.0
Contains all core barcode rendering classes.
Declaration Syntax
C# Visual Basic Visual C++
namespace Zen.Barcode
Namespace Zen.Barcode
namespace Zen.Barcode
Types
All Types Classes Structures Interfaces Enumerations
Icon | Type | Description
 | BarcodeDraw | BarcodeDraw is an abstract base class for all barcode drawing classes.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) | BarcodeDrawBase deals with rendering a barcode using the associated glyph factory and optional checksum generator classes.
 | BarcodeDrawFactory | BarcodeDrawFactory returns draw agents capable of generating the appropriate bar-code image.
 | BarcodeMetrics | BarcodeMetrics defines the measurement metrics used to render a barcode.
 | BarcodeSymbology | BarcodeSymbology defines the supported barcode symbologies.
 | BarGlyph | BarGlyph extends the Glyph base class and adds a bit-encoding to describe a bar-code glyph.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) | BinaryPitchBarcodeDraw is an abstract class that serves as a base class for rendering all dual-pitch barcode symbologies.
 | BinaryPitchGlyph | BinaryPitchGlyph represents a two-state variable pitched barcode glyph characters (Code 3 of 9 is a good example) where character bars or spaces can be one of two widths.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) | BinaryPitchVaryLengthBarcodeDraw serves as a base class for all barcode symbologies using two pitch representation of bars with variable length encoding in each glyph.
 | BinaryPitchVaryLengthGlyph | Represents a barcode symbology where characters have different two width settings and a variable number of encoding bits.
 | Checksum | Checksum defines the base class for generating the bar-code glyphs needed for adding checksum information.
 | Code11BarcodeDraw | Code11BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code11 barcodes with or without checksum.
 | Code11Checksum | Code11Checksum implements a Code11 checksum generator as a singleton class.
 | Code11GlyphFactory | Code11GlyphFactory concrete implementation of GlyphFactory for providing Code 11 bar-code glyph objects.
 | Code128BarcodeDraw | Code128BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code128 barcodes with checksum.
 | Code128Checksum | Code128Checksum implements a Code128 checksum generator as a singleton class.
 | Code128Glyph | Code128Glyph extends MultisetGlyph by defining the three Code128 barcode sections.
 | Code128GlyphFactory | Code128GlyphFactory concrete implementation of GlyphFactory for providing Code 128 bar-code glyph objects.
 | Code128SpecialGlyph | Defines special control codes which have no character representation.
 | Code25BarcodeDraw | Code25StandardBarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code25Standard barcodes with or without checksum.
 | Code25Checksum | Code25Checksum implements a Code25Standard checksum generator as a singleton class.
 | Code25GlyphFactory | Code25GlyphFactory base class for all code 25 GlyphFactory objects.
 | Code25InterleavedGlyphFactory | Code25InterleavedGlyphFactory concrete implementation of GlyphFactory for providing Code 25 bar-code glyph objects.
 | Code25StandardGlyphFactory | Code25StandardGlyphFactory concrete implementation of GlyphFactory for providing Code 25 bar-code glyph objects.
 | Code39BarcodeDraw | Code39BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code39 barcodes with or without checksum.
 | Code39Checksum | Code39Checksum implements a Code39 checksum generator as a singleton class.
 | Code39GlyphFactory | Code39GlyphFactory concrete implementation of GlyphFactory for providing Code 39 bar-code glyph objects.
 | Code93BarcodeDraw | Code93BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code93 barcodes with checksum.
 | Code93Checksum | Code93Checksum implements a Code93 checksum generator as a singleton class.
 | Code93GlyphFactory | Code93GlyphFactory concrete implementation of GlyphFactory for providing Code 93 bar-code glyph objects.
 | CodeEan13BarcodeDraw | CodeEan13BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code EAN 13 barcodes with checksum.
 | CodeEan13Checksum | CodeEan13Checksum implements a Code EAN-13 checksum generator as a singleton class.
 | CodeEan13GlyphFactory | CodeEan13GlyphFactory concrete implementation of GlyphFactory for providing Code EAN 13 bar-code glyph objects.
 | CodeEan8BarcodeDraw | CodeEan8BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code EAN-8 barcodes with checksum.
 | CodeEan8Checksum | CodeEan8Checksum implements a Code EAN-8 checksum generator as a singleton class.
 | CodeEan8GlyphFactory | CodeEan8GlyphFactory concrete implementation of GlyphFactory for providing Code EAN-8 bar-code glyph objects.
 | CodePdf417BarcodeDraw | Custom barcode drawing class for handling PDF417 2D symbology.
 | CompositeGlyph | Represents a composite glyph.
 | FactoryChecksum<(Of <(T>)>) | FactoryChecksum defines the base class for all checksum classes that are attached to an object derived from GlyphFactory for fetching the checksum glyph characters.
 | Glyph | Glyph represents the base class for describing a barcode character.
 | GlyphFactory | Abstract class factory for retrieval of barcode glyph objects.
 | IBarGlyph | IBarGlyph extends IGlyph by specifying a bit encoding for a given character. The bits indicate where bars are drawn.
 | IBinaryPitchGlyph | IBinaryPitchGlyph defines the contract with binary pitched glyphs.
 | IGlyph | IGlyph defines barcode for a given character.
 | IVaryLengthGlyph | IVaryLengthGlyph identifies a glyph object as supporting a custom bit encoding width
 | MultisetGlyph | MultisetGlyph serves as a base class for barcode symbologies where a given encoding is reused by multiple characters.
 | PdfRenderFlags |
 | VaryLengthGlyph | VaryLengthGlyph serves as a base class for variable length fixed-pitch bar-code glyphs.

© Zen Design 2006 - 2008


BarcodeDraw Class

BarcodeDraw Class
Namespaces ► Zen.Barcode ► BarcodeDraw
Barcode Framework Version: v2.0.3.0
BarcodeDraw is an abstract base class for all barcode drawing classes.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BarcodeDraw
Public MustInherit Class BarcodeDraw
public ref class BarcodeDraw abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BarcodeDraw()()() | Initializes a new instance of BarcodeDraw class.
 | Draw(String, Int32, Int32) | Draws a fixed-pitch barcode for the specified text.
 | Draw(String, Int32, Int32, Int32, Int32) | Draws a variable-pitched barcode for the specified text.
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Draws the specified text.
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultMetrics(Int32) | Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)
 |  | CodePdf417BarcodeDraw

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Core (Module: Zen.Barcode.Core) Version: 2.0.3.0 (2.0.3.0)


BarcodeDraw Constructor

BarcodeDraw Constructor
Namespaces ► Zen.Barcode ► BarcodeDraw ► BarcodeDraw()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
protected BarcodeDraw()
Protected Sub New
protected:
BarcodeDraw()


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Draws a fixed-pitch barcode for the specified text.
 | Draw(String, Int32, Int32, Int32, Int32) | Draws a variable-pitched barcode for the specified text.
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Draws the specified text.
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


Draw Method (text, maxBarHeight)

Draw Method (text, maxBarHeight)
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw(String, Int32)
Barcode Framework Version: v2.0.3.0
Draws the specified text using the default barcode metrics for the specified maximum barcode height.
Declaration Syntax
C# Visual Basic Visual C++
public Image Draw(
    string text,
    int maxBarHeight
)
Public Function Draw ( _
    text As String, _
    maxBarHeight As Integer _
) As Image
public:
Image^ Draw(
    String^ text,
    int maxBarHeight
)
Parameters
text (String)
The text.
maxBarHeight (Int32)
The maximum bar height.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDraw.Draw(System.String,System.Int32)]


Draw Method (text, barHeight, barWidth)

Draw Method (text, barHeight, barWidth)
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw(String, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws a fixed-pitch barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public abstract Image Draw(
    string text,
    int barHeight,
    int barWidth
)
Public MustOverride Function Draw ( _
    text As String, _
    barHeight As Integer, _
    barWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barHeight,
    int barWidth
) abstract
Parameters
text (String)
The text.
barHeight (Int32)
Height of the bar.
barWidth (Int32)
Width of the bar.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDraw.Draw(System.String,System.Int32,System.Int32)]


Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw(String, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws a variable-pitched barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public abstract Image Draw(
    string text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public MustOverride Function Draw ( _
    text As String, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) abstract
Parameters
text (String)
The text.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDraw.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32)]


Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw(String, Int32, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public abstract Image Draw(
    string text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public MustOverride Function Draw ( _
    text As String, _
    interGlyphSpace As Integer, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) abstract
Parameters
text (String)
The text.
interGlyphSpace (Int32)
Amount of inter-glyph space (in pixels) to apply.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDraw.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)]


Draw Method (text, metrics)

Draw Method (text, metrics)
Namespaces ► Zen.Barcode ► BarcodeDraw ► Draw(String, BarcodeMetrics)
Barcode Framework Version: v2.0.3.0
Draws the specified text using the supplied barcode metrics.
Declaration Syntax
C# Visual Basic Visual C++
public Image Draw(
    string text,
    BarcodeMetrics metrics
)
Public Function Draw ( _
    text As String, _
    metrics As BarcodeMetrics _
) As Image
public:
Image^ Draw(
    String^ text,
    BarcodeMetrics metrics
)
Parameters
text (String)
The text.
metrics (BarcodeMetrics)
A BarcodeMetrics object.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDraw.Draw(System.String,Zen.Barcode.BarcodeMetrics)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public abstract BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public MustOverride Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) abstract
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public abstract BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public MustOverride Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) abstract
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


BarcodeDrawBase(TGlyphFactory, TChecksum) Class

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Class
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)
Barcode Framework Version: v2.0.3.0
BarcodeDrawBase deals with rendering a barcode using the associated glyph factory and optional checksum generator classes.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BarcodeDrawBase<TGlyphFactory, TChecksum> : BarcodeDraw
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum

Public MustInherit Class BarcodeDrawBase(Of TGlyphFactory As GlyphFactory, TChecksum As Checksum) _
    Inherits BarcodeDraw
generic<typename TGlyphFactory, typename TChecksum>
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum
public ref class BarcodeDrawBase abstract : public BarcodeDraw
Generic Template Parameters
TGlyphFactory
A GlyphFactory derived type.
TChecksum
A Checksum derived type.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BarcodeDraw.
 | Checksum | Gets the TChecksum checksum object.
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing.
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Gets the length in pixels needed to render the specified barcode.
 | GetDefaultInterGlyphSpace(Int32, Int32) | Gets the default amount of inter-glyph space to apply.
 | GetDefaultMetrics(Int32) | Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Inherited from BarcodeDraw.)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count.
 | GetFullBarcode(String) | Gets the glyphs needed to render a full barcode.
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Inherited from BarcodeDraw.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port.
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph.
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information.
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)
 |  |  | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
 |  |  | Code128BarcodeDraw
 |  |  | Code25BarcodeDraw
 |  |  | Code93BarcodeDraw
 |  |  | CodeEan13BarcodeDraw
 |  |  | CodeEan8BarcodeDraw


BarcodeDrawBase(TGlyphFactory, TChecksum) Constructor

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Constructor
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BarcodeDraw.
 | BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BarcodeDraw.


BarcodeDrawBase(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount)

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BarcodeDrawBase(
    TGlyphFactory factory,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer _
)
protected:
BarcodeDrawBase(
    TGlyphFactory factory,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BarcodeDrawBase(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount, widthBitCount)

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BarcodeDrawBase(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BarcodeDrawBase(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


BarcodeDrawBase(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount)

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BarcodeDrawBase(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer _
)
protected:
BarcodeDrawBase(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BarcodeDrawBase(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount, widthBitCount)

BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BarcodeDrawBase(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BarcodeDrawBase(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


Checksum Property

Checksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Checksum
Barcode Framework Version: v2.0.3.0
Gets the TChecksum checksum object.
Declaration Syntax
C# Visual Basic Visual C++
protected TChecksum Checksum { get; }
Protected ReadOnly Property Checksum As TChecksum
protected:
property TChecksum Checksum {
    TChecksum get ();
}
Value
The TChecksum checksum.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


Draw Method (text, barHeight, barWidth)

Draw Method (text, barHeight, barWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Draw(String, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Draws a fixed-pitch barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int barHeight,
    int barWidth
)
Public Overrides Function Draw ( _
    text As String, _
    barHeight As Integer, _
    barWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barHeight,
    int barWidth
) override
Parameters
text (String)
The text.
barHeight (Int32)
Height of the bar.
barWidth (Int32)
Width of the bar.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDrawBase`2.Draw(System.String,System.Int32,System.Int32)]


Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Draw(String, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Draws a variable-pitched barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public Overrides Function Draw ( _
    text As String, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
text (String)
The text.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDrawBase`2.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32)]


Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Draw(String, Int32, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Draws the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public Overrides Function Draw ( _
    text As String, _
    interGlyphSpace As Integer, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
text (String)
The text.
interGlyphSpace (Int32)
Amount of inter-glyph space (in pixels) to apply.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BarcodeDrawBase`2.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)]


EncodingBitCount Property

EncodingBitCount Property
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► EncodingBitCount
Barcode Framework Version: v2.0.3.0
Gets the number of bits used for a glyph encoding.
Declaration Syntax
C# Visual Basic Visual C++
protected int EncodingBitCount { get; }
Protected ReadOnly Property EncodingBitCount As Integer
protected:
property int EncodingBitCount {
    int get ();
}
Value
Number of bits used to represent the glyph encoding.


Factory Property

Factory Property
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Factory
Barcode Framework Version: v2.0.3.0
Gets the TGlyphFactory glyph factory.
Declaration Syntax
C# Visual Basic Visual C++
protected TGlyphFactory Factory { get; }
Protected ReadOnly Property Factory As TGlyphFactory
protected:
property TGlyphFactory Factory {
    TGlyphFactory get ();
}
Value
The TGlyphFactory factory.


GetBarcodeInterGlyphLength Method (barcode, interGlyphSpace)

GetBarcodeInterGlyphLength Method (barcode, interGlyphSpace)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32)
Barcode Framework Version: v2.0.3.0
Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing.
Declaration Syntax
C# Visual Basic Visual C++
protected int GetBarcodeInterGlyphLength(
    Glyph[] barcode,
    int interGlyphSpace
)
Protected Function GetBarcodeInterGlyphLength ( _
    barcode As Glyph(), _
    interGlyphSpace As Integer _
) As Integer
protected:
int GetBarcodeInterGlyphLength(
    array<Glyph^>^ barcode,
    int interGlyphSpace
)
Parameters
barcode (array< Glyph >[]()[])
Collection of Glyph objects to be rendered.
interGlyphSpace (Int32)
Amount of inter-glyph space (in pixels) to be applied.
Return Value
Width in pixels.


GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)

GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Gets the length in pixels needed to render the specified barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetBarcodeLength(
    Glyph[] barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
)
Protected Overridable Function GetBarcodeLength ( _
    barcode As Glyph(), _
    interGlyphSpace As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetBarcodeLength(
    array<Glyph^>^ barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
)
Parameters
barcode (array< Glyph >[]()[])
Barcode glyphs to be analysed.
interGlyphSpace (Int32)
Amount of inter-glyph space.
barMinWidth (Int32)
Minimum barcode width.
barMaxWidth (Int32)
Maximum barcode width.
Return Value
The barcode width in pixels.
Remarks
Currently this method does not account for any "quiet space" around the barcode as dictated by each symbology standard.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Gets the default amount of inter-glyph space to apply.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overridable Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Parameters
barMinWidth (Int32)
The min bar width in pixels.
barMaxWidth (Int32)
The max bar width in pixels.
Return Value
The amount of inter-glyph spacing to apply in pixels.
Remarks
By default this method returns zero.


GetEncodingBitCount Method (glyph)

GetEncodingBitCount Method (glyph)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetEncodingBitCount(Glyph)
Barcode Framework Version: v2.0.3.0
Gets the glyph's barcode encoding bit count.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetEncodingBitCount(
    Glyph glyph
)
Protected Overridable Function GetEncodingBitCount ( _
    glyph As Glyph _
) As Integer
protected:
virtual int GetEncodingBitCount(
    Glyph^ glyph
)
Parameters
glyph (Glyph)
A Glyph to be queried.
Return Value
Number of bits needed to encode the glyph.
Remarks
By default this method returns the underlying encoding bit width. If the glyph implements IVaryLengthGlyph then the encoding width is requested from the interface.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract Glyph[] GetFullBarcode(
    string text
)
Protected MustOverride Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) abstract
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)

GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetGlyphHeight(Glyph, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Gets the height of the glyph.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetGlyphHeight(
    Glyph glyph,
    int barMinHeight,
    int barMaxHeight
)
Protected Overridable Function GetGlyphHeight ( _
    glyph As Glyph, _
    barMinHeight As Integer, _
    barMaxHeight As Integer _
) As Integer
protected:
virtual int GetGlyphHeight(
    Glyph^ glyph,
    int barMinHeight,
    int barMaxHeight
)
Parameters
glyph (Glyph)
A Glyph to be queried.
barMinHeight (Int32)
Minimum bar height in pixels.
barMaxHeight (Int32)
Maximum bar height in pixels.
Return Value
The height of associated glyph.
Remarks
By default this method returns the maximum bar height.


GetWidthBitCount Method (glyph)

GetWidthBitCount Method (glyph)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► GetWidthBitCount(Glyph)
Barcode Framework Version: v2.0.3.0
Gets the glyph's width encoding bit count.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetWidthBitCount(
    Glyph glyph
)
Protected Overridable Function GetWidthBitCount ( _
    glyph As Glyph _
) As Integer
protected:
virtual int GetWidthBitCount(
    Glyph^ glyph
)
Parameters
glyph (Glyph)
A Glyph to be queried.
Return Value
Number of bits needed to encode the width of the glyph.
Remarks
By default this method returns the underlying width bit count.


Render Method (barcode, dc, bounds, interGlyphSpace, barMinHeight, barMinWidth, barMaxWidth)

Render Method (barcode, dc, bounds, interGlyphSpace, barMinHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Renders the specified bar-code to the specified graphics port.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Render(
    Glyph[] barcode,
    Graphics dc,
    Rectangle bounds,
    int interGlyphSpace,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Protected Overridable Sub Render ( _
    barcode As Glyph(), _
    dc As Graphics, _
    bounds As Rectangle, _
    interGlyphSpace As Integer, _
    barMinHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
)
protected:
virtual void Render(
    array<Glyph^>^ barcode,
    Graphics^ dc,
    Rectangle bounds,
    int interGlyphSpace,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Parameters
barcode (array< Glyph >[]()[])
A collection of Glyph objects representing the barcode to be rendered.
dc (Graphics)
A Graphics representing the draw context.
bounds (Rectangle)
The bounding rectangle.
interGlyphSpace (Int32)
The inter glyph space in pixels.
barMinHeight (Int32)
Minimum bar height in pixels.
barMinWidth (Int32)
Small bar width in pixels.
barMaxWidth (Int32)
Large bar width in pixels.
Remarks
This method clears the background and then calls [M:RenderBars] to perform the actual bar drawing.


RenderBar Method (glyph, dc, bounds, barOffset, barMinHeight, barMinWidth, barMaxWidth)

RenderBar Method (glyph, dc, bounds, barOffset, barMinHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Renders the bar-code glyph.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RenderBar(
    BarGlyph glyph,
    Graphics dc,
    Rectangle bounds,
    ref int barOffset,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Protected Overridable Sub RenderBar ( _
    glyph As BarGlyph, _
    dc As Graphics, _
    bounds As Rectangle, _
    ByRef barOffset As Integer, _
    barMinHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
)
protected:
virtual void RenderBar(
    BarGlyph^ glyph,
    Graphics^ dc,
    Rectangle bounds,
    int% barOffset,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Parameters
glyph (BarGlyph)
A Glyph object to be rendered.
dc (Graphics)
A Graphics representing the draw context.
bounds (Rectangle)
The bounding rectangle.
barOffset ( Int32 %)
The bar offset.
barMinHeight (Int32)
Minimum bar height in pixels.
barMinWidth (Int32)
Small bar width in pixels.
barMaxWidth (Int32)
Large bar width in pixels.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if the encoding bit count is zero or variable-pitch bar rendering is attempted.


RenderBars Method (barcode, dc, bounds, interGlyphSpace, barMinHeight, barMinWidth, barMaxWidth)

RenderBars Method (barcode, dc, bounds, interGlyphSpace, barMinHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Renders the barcode bars.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RenderBars(
    Glyph[] barcode,
    Graphics dc,
    Rectangle bounds,
    int interGlyphSpace,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Protected Overridable Sub RenderBars ( _
    barcode As Glyph(), _
    dc As Graphics, _
    bounds As Rectangle, _
    interGlyphSpace As Integer, _
    barMinHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
)
protected:
virtual void RenderBars(
    array<Glyph^>^ barcode,
    Graphics^ dc,
    Rectangle bounds,
    int interGlyphSpace,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Parameters
barcode (array< Glyph >[]()[])
A collection of Glyph objects representing the barcode to be rendered.
dc (Graphics)
A Graphics representing the draw context.
bounds (Rectangle)
The bounding rectangle.
interGlyphSpace (Int32)
The inter glyph space in pixels.
barMinHeight (Int32)
Minimum bar height in pixels.
barMinWidth (Int32)
Small bar width in pixels.
barMaxWidth (Int32)
Large bar width in pixels.
Remarks
By default this method renders each glyph by calling the [M:RenderBar] method, applying the specified inter-glyph spacing as necessary.


WidthBitCount Property

WidthBitCount Property
Namespaces ► Zen.Barcode ► BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>) ► WidthBitCount
Barcode Framework Version: v2.0.3.0
Gets the number of bits used to encode the glyph width information.
Declaration Syntax
C# Visual Basic Visual C++
protected int WidthBitCount { get; }
Protected ReadOnly Property WidthBitCount As Integer
protected:
property int WidthBitCount {
    int get ();
}
Value
Number of bits used to represent bar width encoding.


BarcodeDrawFactory Class

BarcodeDrawFactory Class
Namespaces ► Zen.Barcode ► BarcodeDrawFactory
Barcode Framework Version: v2.0.3.0
BarcodeDrawFactory returns draw agents capable of generating the appropriate bar-code image.
Declaration Syntax
C# Visual Basic Visual C++
public static class BarcodeDrawFactory
Public NotInheritable Class BarcodeDrawFactory
public ref class BarcodeDrawFactory abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Code11WithChecksum | Gets an agent capable of rendering a Code11 barcode with added checksum glyphs.
 | Code11WithoutChecksum | Gets an agent capable of rendering a Code11 barcode.
 | Code128WithChecksum | Gets an agent capable of rendering a Code128 barcode with added checksum glyphs.
 | Code25InterleavedWithChecksum | Gets an agent capable of rendering a Code 25 barcode with added checksum glyphs.
 | Code25InterleavedWithoutChecksum | Gets an agent capable of rendering a Code 25 barcode without checksum glyphs.
 | Code25StandardWithChecksum | Gets an agent capable of rendering a Code 25 barcode with added checksum glyphs.
 | Code25StandardWithoutChecksum | Gets an agent capable of rendering a Code 25 barcode without checksum glyphs.
 | Code39WithChecksum | Gets an agent capable of rendering a Code39 barcode with an added checksum glyph.
 | Code39WithoutChecksum | Gets an agent capable of rendering a Code39 barcode without adding a checksum glyph.
 | Code93WithChecksum | Gets an agent capable of rendering a Code93 barcode with added checksum glyphs.
 | CodeEan13WithChecksum | Gets an agent capable of rendering a Code EAN-13 barcode with added checksum glyphs.
 | CodeEan8WithChecksum | Gets an agent capable of rendering a Code EAN-8 barcode with added checksum glyphs.
 | CodePdf417WithChecksum | Gets an agent capable of rendering a Code PDF417 barcode with added checksum glyphs.
 | GetSymbology(BarcodeSymbology) | Gets the barcode drawing object for rendering the specified barcode symbology.
Inheritance Hierarchy
Object
BarcodeDrawFactory


Code11WithChecksum Property

Code11WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code11WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code11 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code11BarcodeDraw Code11WithChecksum { get; }
Public Shared ReadOnly Property Code11WithChecksum As Code11BarcodeDraw
public:
static property Code11BarcodeDraw^ Code11WithChecksum {
    Code11BarcodeDraw^ get ();
}
Value
A Code11BarcodeDraw object.


Code11WithoutChecksum Property

Code11WithoutChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code11WithoutChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code11 barcode.
Declaration Syntax
C# Visual Basic Visual C++
public static Code11BarcodeDraw Code11WithoutChecksum { get; }
Public Shared ReadOnly Property Code11WithoutChecksum As Code11BarcodeDraw
public:
static property Code11BarcodeDraw^ Code11WithoutChecksum {
    Code11BarcodeDraw^ get ();
}
Value
A Code11BarcodeDraw object.


Code128WithChecksum Property

Code128WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code128WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code128 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code128BarcodeDraw Code128WithChecksum { get; }
Public Shared ReadOnly Property Code128WithChecksum As Code128BarcodeDraw
public:
static property Code128BarcodeDraw^ Code128WithChecksum {
    Code128BarcodeDraw^ get ();
}
Value
A Code128BarcodeDraw object.


Code25InterleavedWithChecksum Property

Code25InterleavedWithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code25InterleavedWithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code 25 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25BarcodeDraw Code25InterleavedWithChecksum { get; }
Public Shared ReadOnly Property Code25InterleavedWithChecksum As Code25BarcodeDraw
public:
static property Code25BarcodeDraw^ Code25InterleavedWithChecksum {
    Code25BarcodeDraw^ get ();
}
Value
A Code25BarcodeDraw object.


Code25InterleavedWithoutChecksum Property

Code25InterleavedWithoutChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code25InterleavedWithoutChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code 25 barcode without checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25BarcodeDraw Code25InterleavedWithoutChecksum { get; }
Public Shared ReadOnly Property Code25InterleavedWithoutChecksum As Code25BarcodeDraw
public:
static property Code25BarcodeDraw^ Code25InterleavedWithoutChecksum {
    Code25BarcodeDraw^ get ();
}
Value
A Code25BarcodeDraw object.


Code25StandardWithChecksum Property

Code25StandardWithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code25StandardWithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code 25 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25BarcodeDraw Code25StandardWithChecksum { get; }
Public Shared ReadOnly Property Code25StandardWithChecksum As Code25BarcodeDraw
public:
static property Code25BarcodeDraw^ Code25StandardWithChecksum {
    Code25BarcodeDraw^ get ();
}
Value
A Code25BarcodeDraw object.


Code25StandardWithoutChecksum Property

Code25StandardWithoutChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code25StandardWithoutChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code 25 barcode without checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25BarcodeDraw Code25StandardWithoutChecksum { get; }
Public Shared ReadOnly Property Code25StandardWithoutChecksum As Code25BarcodeDraw
public:
static property Code25BarcodeDraw^ Code25StandardWithoutChecksum {
    Code25BarcodeDraw^ get ();
}
Value
A Code25BarcodeDraw object.


Code39WithChecksum Property

Code39WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code39WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code39 barcode with an added checksum glyph.
Declaration Syntax
C# Visual Basic Visual C++
public static Code39BarcodeDraw Code39WithChecksum { get; }
Public Shared ReadOnly Property Code39WithChecksum As Code39BarcodeDraw
public:
static property Code39BarcodeDraw^ Code39WithChecksum {
    Code39BarcodeDraw^ get ();
}
Value
A Code39BarcodeDraw object.


Code39WithoutChecksum Property

Code39WithoutChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code39WithoutChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code39 barcode without adding a checksum glyph.
Declaration Syntax
C# Visual Basic Visual C++
public static Code39BarcodeDraw Code39WithoutChecksum { get; }
Public Shared ReadOnly Property Code39WithoutChecksum As Code39BarcodeDraw
public:
static property Code39BarcodeDraw^ Code39WithoutChecksum {
    Code39BarcodeDraw^ get ();
}
Value
A Code39BarcodeDraw object.


Code93WithChecksum Property

Code93WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► Code93WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code93 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static Code93BarcodeDraw Code93WithChecksum { get; }
Public Shared ReadOnly Property Code93WithChecksum As Code93BarcodeDraw
public:
static property Code93BarcodeDraw^ Code93WithChecksum {
    Code93BarcodeDraw^ get ();
}
Value
A Code93BarcodeDraw object.


CodeEan13WithChecksum Property

CodeEan13WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► CodeEan13WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code EAN-13 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan13BarcodeDraw CodeEan13WithChecksum { get; }
Public Shared ReadOnly Property CodeEan13WithChecksum As CodeEan13BarcodeDraw
public:
static property CodeEan13BarcodeDraw^ CodeEan13WithChecksum {
    CodeEan13BarcodeDraw^ get ();
}
Value
A CodeEan13BarcodeDraw object.


CodeEan8WithChecksum Property

CodeEan8WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► CodeEan8WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code EAN-8 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan8BarcodeDraw CodeEan8WithChecksum { get; }
Public Shared ReadOnly Property CodeEan8WithChecksum As CodeEan8BarcodeDraw
public:
static property CodeEan8BarcodeDraw^ CodeEan8WithChecksum {
    CodeEan8BarcodeDraw^ get ();
}
Value
A CodeEan8BarcodeDraw object.


CodePdf417WithChecksum Property

CodePdf417WithChecksum Property
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► CodePdf417WithChecksum
Barcode Framework Version: v2.0.3.0
Gets an agent capable of rendering a Code PDF417 barcode with added checksum glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public static CodePdf417BarcodeDraw CodePdf417WithChecksum { get; }
Public Shared ReadOnly Property CodePdf417WithChecksum As CodePdf417BarcodeDraw
public:
static property CodePdf417BarcodeDraw^ CodePdf417WithChecksum {
    CodePdf417BarcodeDraw^ get ();
}
Value
A Code25BarcodeDraw object.


GetSymbology Method (symbology)

GetSymbology Method (symbology)
Namespaces ► Zen.Barcode ► BarcodeDrawFactory ► GetSymbology(BarcodeSymbology)
Barcode Framework Version: v2.0.3.0
Gets the barcode drawing object for rendering the specified barcode symbology.
Declaration Syntax
C# Visual Basic Visual C++
public static BarcodeDraw GetSymbology(
    BarcodeSymbology symbology
)
Public Shared Function GetSymbology ( _
    symbology As BarcodeSymbology _
) As BarcodeDraw
public:
static BarcodeDraw^ GetSymbology(
    BarcodeSymbology symbology
)
Parameters
symbology (BarcodeSymbology)
A value from the BarcodeSymbology enumeration.
Return Value
A class derived from BarcodeDraw.
Exceptions
Exception | Condition
ArgumentException | Thrown if the specified symbology is invalid or unknown.


BarcodeMetrics Structure

BarcodeMetrics Structure
Namespaces ► Zen.Barcode ► BarcodeMetrics
Barcode Framework Version: v2.0.3.0
BarcodeMetrics defines the measurement metrics used to render a barcode.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public struct BarcodeMetrics
<SerializableAttribute> _
Public Structure BarcodeMetrics
[SerializableAttribute]
public value class BarcodeMetrics
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeMetrics(Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.
 | BarcodeMetrics(Int32, Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.
 | BarcodeMetrics(Int32, Int32, Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterGlyphSpacing | Gets/sets the amount of inter-glyph spacing to apply.
 | MaxHeight | Gets/sets the maximum bar height.
 | MaxWidth | Gets/sets the maximum bar width.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | Gets/sets the minimum bar height.
 | MinWidth | Gets/sets the minimum bar width.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BarcodeMetrics Constructor

BarcodeMetrics Constructor
Namespaces ► Zen.Barcode ► BarcodeMetrics ► BarcodeMetrics()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | BarcodeMetrics(Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.
 | BarcodeMetrics(Int32, Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.
 | BarcodeMetrics(Int32, Int32, Int32, Int32) | Initializes a new instance of BarcodeMetrics structure.


BarcodeMetrics Constructor (width, height)

BarcodeMetrics Constructor (width, height)
Namespaces ► Zen.Barcode ► BarcodeMetrics ► BarcodeMetrics(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of BarcodeMetrics structure.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeMetrics(
    int width,
    int height
)
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
public:
BarcodeMetrics(
    int width,
    int height
)
Parameters
width (Int32)

[Missing <param name="width"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32)"]

height (Int32)

[Missing <param name="height"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32)"]


BarcodeMetrics Constructor (minWidth, maxWidth, height)

BarcodeMetrics Constructor (minWidth, maxWidth, height)
Namespaces ► Zen.Barcode ► BarcodeMetrics ► BarcodeMetrics(Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of BarcodeMetrics structure.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeMetrics(
    int minWidth,
    int maxWidth,
    int height
)
Public Sub New ( _
    minWidth As Integer, _
    maxWidth As Integer, _
    height As Integer _
)
public:
BarcodeMetrics(
    int minWidth,
    int maxWidth,
    int height
)
Parameters
minWidth (Int32)

[Missing <param name="minWidth"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32)"]

maxWidth (Int32)

[Missing <param name="maxWidth"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32)"]

height (Int32)

[Missing <param name="height"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32)"]


BarcodeMetrics Constructor (minWidth, maxWidth, minHeight, maxHeight)

BarcodeMetrics Constructor (minWidth, maxWidth, minHeight, maxHeight)
Namespaces ► Zen.Barcode ► BarcodeMetrics ► BarcodeMetrics(Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of BarcodeMetrics structure.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeMetrics(
    int minWidth,
    int maxWidth,
    int minHeight,
    int maxHeight
)
Public Sub New ( _
    minWidth As Integer, _
    maxWidth As Integer, _
    minHeight As Integer, _
    maxHeight As Integer _
)
public:
BarcodeMetrics(
    int minWidth,
    int maxWidth,
    int minHeight,
    int maxHeight
)
Parameters
minWidth (Int32)

[Missing <param name="minWidth"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

maxWidth (Int32)

[Missing <param name="maxWidth"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

minHeight (Int32)

[Missing <param name="minHeight"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

maxHeight (Int32)

[Missing <param name="maxHeight"/> documentation for "M:Zen.Barcode.BarcodeMetrics.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]


InterGlyphSpacing Property

InterGlyphSpacing Property
Namespaces ► Zen.Barcode ► BarcodeMetrics ► InterGlyphSpacing
Barcode Framework Version: v2.0.3.0
Gets/sets the amount of inter-glyph spacing to apply.
Declaration Syntax
C# Visual Basic Visual C++
public int InterGlyphSpacing { get; set; }
Public Property InterGlyphSpacing As Integer
public:
property int InterGlyphSpacing {
    int get ();
    void set (int value);
}
Remarks
By default this is set to -1 which forces the barcode drawing classes to use the default value specified by the symbology.


MaxHeight Property

MaxHeight Property
Namespaces ► Zen.Barcode ► BarcodeMetrics ► MaxHeight
Barcode Framework Version: v2.0.3.0
Gets/sets the maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxHeight { get; set; }
Public Property MaxHeight As Integer
public:
property int MaxHeight {
    int get ();
    void set (int value);
}


MaxWidth Property

MaxWidth Property
Namespaces ► Zen.Barcode ► BarcodeMetrics ► MaxWidth
Barcode Framework Version: v2.0.3.0
Gets/sets the maximum bar width.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxWidth { get; set; }
Public Property MaxWidth As Integer
public:
property int MaxWidth {
    int get ();
    void set (int value);
}


MinHeight Property

MinHeight Property
Namespaces ► Zen.Barcode ► BarcodeMetrics ► MinHeight
Barcode Framework Version: v2.0.3.0
Gets/sets the minimum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public int MinHeight { get; set; }
Public Property MinHeight As Integer
public:
property int MinHeight {
    int get ();
    void set (int value);
}


MinWidth Property

MinWidth Property
Namespaces ► Zen.Barcode ► BarcodeMetrics ► MinWidth
Barcode Framework Version: v2.0.3.0
Gets/sets the minimum bar width.
Declaration Syntax
C# Visual Basic Visual C++
public int MinWidth { get; set; }
Public Property MinWidth As Integer
public:
property int MinWidth {
    int get ();
    void set (int value);
}


BarcodeSymbology Enumeration

BarcodeSymbology Enumeration
Namespaces ► Zen.Barcode ► BarcodeSymbology
Barcode Framework Version: v2.0.3.0
BarcodeSymbology defines the supported barcode symbologies.
Declaration Syntax
C# Visual Basic Visual C++
public enum BarcodeSymbology
Public Enumeration BarcodeSymbology
public enum class BarcodeSymbology
Members
Member | Description
Unknown | Unknown symbology.
Code39NC | Code 39 (aka Code 3 of 9) without checksum
Code39C | Code 39 (aka Code 3 of 9) with checksum
Code93 | Code 93 with checksum
Code128 | Code 128 with checksum
Code11NC | Code 11 without checksum
Code11C | Code 11 with checksum
CodeEan13 | Code EAN-13 with checksum
CodeEan8 | Code EAN-8 with checksum
Code25StandardNC | Code 25 standard without checksum
Code25StandardC | Code 25 standard with checksum
Code25InterleavedNC | Code 25 interleaved without checksum
Code25InterleavedC | Code 25 interleaved with checksum
CodePdf417 | Code PDF 417 (2D symbology with variable error correction)


BarGlyph Class

BarGlyph Class
Namespaces ► Zen.Barcode ► BarGlyph
Barcode Framework Version: v2.0.3.0
BarGlyph extends the Glyph base class and adds a bit-encoding to describe a bar-code glyph.
Declaration Syntax
C# Visual Basic Visual C++
public class BarGlyph : Glyph, IBarGlyph,
    IGlyph
Public Class BarGlyph _
    Inherits Glyph _
    Implements IBarGlyph, IGlyph
public ref class BarGlyph : public Glyph,
    IBarGlyph, IGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarGlyph(Char, Int16) | Initialises a new instance of the Glyph class with the specified bit encoding.
 | BitEncoding | Gets the bit encoding for this glyph.
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | BinaryPitchGlyph
 |  |  | MultisetGlyph
 |  |  | VaryLengthGlyph


BarGlyph Constructor (character, bitEncoding)

BarGlyph Constructor (character, bitEncoding)
Namespaces ► Zen.Barcode ► BarGlyph ► BarGlyph(Char, Int16)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of the Glyph class with the specified bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
public BarGlyph(
    char character,
    short bitEncoding
)
Public Sub New ( _
    character As Char, _
    bitEncoding As Short _
)
public:
BarGlyph(
    wchar_t character,
    short bitEncoding
)
Parameters
character (Char)
Character represented by glyph.
bitEncoding (Int16)
The bit-encoding value for this character.


BitEncoding Property

BitEncoding Property
Namespaces ► Zen.Barcode ► BarGlyph ► BitEncoding
Barcode Framework Version: v2.0.3.0
Gets the bit encoding for this glyph.
Declaration Syntax
C# Visual Basic Visual C++
public short BitEncoding { get; }
Public ReadOnly Property BitEncoding As Short
public:
virtual property short BitEncoding {
    short get () sealed;
}
Value
A Int16 representing the bit encoding.


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Class

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Class
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
Barcode Framework Version: v2.0.3.0
BinaryPitchBarcodeDraw is an abstract class that serves as a base class for rendering all dual-pitch barcode symbologies.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BinaryPitchBarcodeDraw<TGlyphFactory, TChecksum> : BarcodeDrawBase<TGlyphFactory, TChecksum>
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum

Public MustInherit Class BinaryPitchBarcodeDraw(Of TGlyphFactory As GlyphFactory, TChecksum As Checksum) _
    Inherits BarcodeDrawBase(Of TGlyphFactory, TChecksum)
generic<typename TGlyphFactory, typename TChecksum>
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum
public ref class BinaryPitchBarcodeDraw abstract : public BarcodeDrawBase<TGlyphFactory, TChecksum>
Generic Template Parameters
TGlyphFactory
The glyph factory type derived from GlyphFactory.
TChecksum
The checksum type derived from Checksum.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the barcode length. (Overrides BarcodeDrawBase <(Of <(TGlyphFactory, TChecksum>)>).GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Gets the default amount of inter-glyph space to apply. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultMetrics(Int32) | Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Inherited from BarcodeDraw.)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Gets the glyphs needed to render a full barcode. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetGlyphEncodingBitCount(Glyph) | Gets the glyph's encoding bit width.
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Inherited from BarcodeDraw.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Overridden. Renders the specified glyph. (Overrides BarcodeDrawBase <(Of <(TGlyphFactory, TChecksum>)>).RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <(TGlyphFactory, TChecksum>)>)
 |  |  | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
 |  |  |  | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
 |  |  |  | Code39BarcodeDraw


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Constructor

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.
 | BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BinaryPitchBarcodeDraw.


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount)

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer _
)
protected:
BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount, widthBitCount)

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount)

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer _
)
protected:
BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BinaryPitchBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount, widthBitCount)

BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BinaryPitchBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)

GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the barcode length.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetBarcodeLength(
    Glyph[] barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetBarcodeLength ( _
    barcode As Glyph(), _
    interGlyphSpace As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetBarcodeLength(
    array<Glyph^>^ barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barcode (array< Glyph >[]()[])
Barcode glyphs to be analysed.
interGlyphSpace (Int32)
Amount of inter-glyph space.
barMinWidth (Int32)
Minimum barcode width.
barMaxWidth (Int32)
Maximum barcode width.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.BinaryPitchBarcodeDraw`2.GetBarcodeLength(Zen.Barcode.Glyph[],System.Int32,System.Int32,System.Int32)]


GetGlyphEncodingBitCount Method (glyph)

GetGlyphEncodingBitCount Method (glyph)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► GetGlyphEncodingBitCount(Glyph)
Barcode Framework Version: v2.0.3.0
Gets the glyph's encoding bit width.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int GetGlyphEncodingBitCount(
    Glyph glyph
)
Protected Overridable Function GetGlyphEncodingBitCount ( _
    glyph As Glyph _
) As Integer
protected:
virtual int GetGlyphEncodingBitCount(
    Glyph^ glyph
)
Parameters
glyph (Glyph)
The Glyph to be queried.
Return Value
Number of bits used to encode the glyph.
Remarks
By default this method returns the underlying encoding bit width.


RenderBar Method (glyph, dc, bounds, barOffset, barMinHeight, barMinWidth, barMaxWidth)

RenderBar Method (glyph, dc, bounds, barOffset, barMinHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Renders the specified glyph.
Declaration Syntax
C# Visual Basic Visual C++
protected override void RenderBar(
    BarGlyph glyph,
    Graphics dc,
    Rectangle bounds,
    ref int barOffset,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Sub RenderBar ( _
    glyph As BarGlyph, _
    dc As Graphics, _
    bounds As Rectangle, _
    ByRef barOffset As Integer, _
    barMinHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
)
protected:
virtual void RenderBar(
    BarGlyph^ glyph,
    Graphics^ dc,
    Rectangle bounds,
    int% barOffset,
    int barMinHeight,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
glyph (BarGlyph)
A Glyph to be rendered.
dc (Graphics)
A Graphics representing the device context.
bounds (Rectangle)
The bounding rectangle.
barOffset ( Int32 %)
The bar offset in pixels.
barMinHeight (Int32)
Minimum bar height in pixels.
barMinWidth (Int32)
Minimum bar width.
barMaxWidth (Int32)
Maximum bar width.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if the encoding bit count is zero or variable-pitch bar rendering is attempted.


BinaryPitchGlyph Class

BinaryPitchGlyph Class
Namespaces ► Zen.Barcode ► BinaryPitchGlyph
Barcode Framework Version: v2.0.3.0
BinaryPitchGlyph represents a two-state variable pitched barcode glyph characters (Code 3 of 9 is a good example) where character bars or spaces can be one of two widths.
Declaration Syntax
C# Visual Basic Visual C++
public class BinaryPitchGlyph : BarGlyph,
    IBinaryPitchGlyph, IBarGlyph, IGlyph
Public Class BinaryPitchGlyph _
    Inherits BarGlyph _
    Implements IBinaryPitchGlyph, IBarGlyph, IGlyph
public ref class BinaryPitchGlyph : public BarGlyph,
    IBinaryPitchGlyph, IBarGlyph, IGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryPitchGlyph(Char, Int16, Int16) | Initialises a new instance of the BinaryPitchGlyph class.
 | BitEncoding | Gets the bit encoding for this glyph. (Inherited from BarGlyph.)
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthEncoding | Gets the width encoding.
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | BinaryPitchGlyph
 |  |  |  | BinaryPitchVaryLengthGlyph


BinaryPitchGlyph Constructor (character, bitEncoding, widthEncoding)

BinaryPitchGlyph Constructor (character, bitEncoding, widthEncoding)
Namespaces ► Zen.Barcode ► BinaryPitchGlyph ► BinaryPitchGlyph(Char, Int16, Int16)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of the BinaryPitchGlyph class.
Declaration Syntax
C# Visual Basic Visual C++
public BinaryPitchGlyph(
    char character,
    short bitEncoding,
    short widthEncoding
)
Public Sub New ( _
    character As Char, _
    bitEncoding As Short, _
    widthEncoding As Short _
)
public:
BinaryPitchGlyph(
    wchar_t character,
    short bitEncoding,
    short widthEncoding
)
Parameters
character (Char)
The character.
bitEncoding (Int16)
The bit encoding.
widthEncoding (Int16)
The width encoding.


WidthEncoding Property

WidthEncoding Property
Namespaces ► Zen.Barcode ► BinaryPitchGlyph ► WidthEncoding
Barcode Framework Version: v2.0.3.0
Gets the width encoding.
Declaration Syntax
C# Visual Basic Visual C++
public short WidthEncoding { get; }
Public ReadOnly Property WidthEncoding As Short
public:
virtual property short WidthEncoding {
    short get () sealed;
}
Value
The width encoding.


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Class

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Class
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
Barcode Framework Version: v2.0.3.0
BinaryPitchVaryLengthBarcodeDraw serves as a base class for all barcode symbologies using two pitch representation of bars with variable length encoding in each glyph.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BinaryPitchVaryLengthBarcodeDraw<TGlyphFactory, TChecksum> : BinaryPitchBarcodeDraw<TGlyphFactory, TChecksum>
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum

Public MustInherit Class BinaryPitchVaryLengthBarcodeDraw(Of TGlyphFactory As GlyphFactory, TChecksum As Checksum) _
    Inherits BinaryPitchBarcodeDraw(Of TGlyphFactory, TChecksum)
generic<typename TGlyphFactory, typename TChecksum>
where TGlyphFactory : GlyphFactory
where TChecksum : Checksum
public ref class BinaryPitchVaryLengthBarcodeDraw abstract : public BinaryPitchBarcodeDraw<TGlyphFactory, TChecksum>
Generic Template Parameters
TGlyphFactory
The glyph factory type derived from GlyphFactory.
TChecksum
The checksum type derived from Checksum.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the barcode length. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Gets the default amount of inter-glyph space to apply. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultMetrics(Int32) | Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Inherited from BarcodeDraw.)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Gets the glyphs needed to render a full barcode. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetGlyphEncodingBitCount(Glyph) | Overridden. Gets the glyph's encoding bit width. (Overrides BinaryPitchBarcodeDraw <(Of <(TGlyphFactory, TChecksum>)>).GetGlyphEncodingBitCount(Glyph).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Inherited from BarcodeDraw.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Overridden. Renders the specified glyph. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <(TGlyphFactory, TChecksum>)>)
 |  |  | BinaryPitchBarcodeDraw <(Of <(TGlyphFactory, TChecksum>)>)
 |  |  |  | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)
 |  |  |  |  | Code11BarcodeDraw


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Constructor

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32) | Initialises an instance of BarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
 | BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32) | Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount)

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer _
)
protected:
BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, encodingBitCount, widthBitCount)

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount)

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer _
)
protected:
BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.


BinaryPitchVaryLengthBarcodeDraw(TGlyphFactory, TChecksum) Constructor (factory, checksum, encodingBitCount, widthBitCount)

BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) Constructor (factory, checksum, encodingBitCount, widthBitCount)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>)(TGlyphFactory, TChecksum, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Initialises an instance of BinaryPitchVaryLengthBarcodeDraw.
Declaration Syntax
C# Visual Basic Visual C++
protected BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Protected Sub New ( _
    factory As TGlyphFactory, _
    checksum As TChecksum, _
    encodingBitCount As Integer, _
    widthBitCount As Integer _
)
protected:
BinaryPitchVaryLengthBarcodeDraw(
    TGlyphFactory factory,
    TChecksum checksum,
    int encodingBitCount,
    int widthBitCount
)
Parameters
factory (TGlyphFactory)
The factory.
checksum (TChecksum)
The checksum.
encodingBitCount (Int32)
Number of bits in each encoded glyph. Set to 0 for variable length bit encoded glyphs.
widthBitCount (Int32)
Width of the width bit.


GetGlyphEncodingBitCount Method (glyph)

GetGlyphEncodingBitCount Method (glyph)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► GetGlyphEncodingBitCount(Glyph)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyph's encoding bit width.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetGlyphEncodingBitCount(
    Glyph glyph
)
Protected Overrides Function GetGlyphEncodingBitCount ( _
    glyph As Glyph _
) As Integer
protected:
virtual int GetGlyphEncodingBitCount(
    Glyph^ glyph
) override
Parameters
glyph (Glyph)
The Glyph to be queried.
Return Value
Number of bits used to encode the glyph.
Exceptions
Exception | Condition
InvalidCastException | If the passed glyph is not derived from BinaryPitchVaryLengthGlyph.


BinaryPitchVaryLengthGlyph Class

BinaryPitchVaryLengthGlyph Class
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthGlyph
Barcode Framework Version: v2.0.3.0
Represents a barcode symbology where characters have different two width settings and a variable number of encoding bits.
Declaration Syntax
C# Visual Basic Visual C++
public class BinaryPitchVaryLengthGlyph : BinaryPitchGlyph,
    IVaryLengthGlyph, IBarGlyph, IGlyph
Public Class BinaryPitchVaryLengthGlyph _
    Inherits BinaryPitchGlyph _
    Implements IVaryLengthGlyph, IBarGlyph, IGlyph
public ref class BinaryPitchVaryLengthGlyph : public BinaryPitchGlyph,
    IVaryLengthGlyph, IBarGlyph, IGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryPitchVaryLengthGlyph(Char, Int16, Int16, Int16) | Initialises a new instance of the BinaryPitchGlyph class.
 | BitEncoding | Gets the bit encoding for this glyph. (Inherited from BarGlyph.)
 | BitEncodingWidth | Gets the number of bits used for the bit encoding.
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthEncoding | Gets the width encoding. (Inherited from BinaryPitchGlyph.)
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | BinaryPitchGlyph
 |  |  |  | BinaryPitchVaryLengthGlyph


BinaryPitchVaryLengthGlyph Constructor (character, bitEncoding, widthEncoding, bitEncodingWidth)

BinaryPitchVaryLengthGlyph Constructor (character, bitEncoding, widthEncoding, bitEncodingWidth)
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthGlyph ► BinaryPitchVaryLengthGlyph(Char, Int16, Int16, Int16)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of the BinaryPitchGlyph class.
Declaration Syntax
C# Visual Basic Visual C++
public BinaryPitchVaryLengthGlyph(
    char character,
    short bitEncoding,
    short widthEncoding,
    short bitEncodingWidth
)
Public Sub New ( _
    character As Char, _
    bitEncoding As Short, _
    widthEncoding As Short, _
    bitEncodingWidth As Short _
)
public:
BinaryPitchVaryLengthGlyph(
    wchar_t character,
    short bitEncoding,
    short widthEncoding,
    short bitEncodingWidth
)
Parameters
character (Char)
The character.
bitEncoding (Int16)
The bit encoding.
widthEncoding (Int16)
The width encoding.
bitEncodingWidth (Int16)
The bit encoding width expressed as a number of bits.


BitEncodingWidth Property

BitEncodingWidth Property
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthGlyph ► BitEncodingWidth
Barcode Framework Version: v2.0.3.0
Gets the number of bits used for the bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
public short BitEncodingWidth { get; }
Public ReadOnly Property BitEncodingWidth As Short
public:
virtual property short BitEncodingWidth {
    short get () sealed;
}
Value
The width encoding.


Checksum Class

Checksum Class
Namespaces ► Zen.Barcode ► Checksum
Barcode Framework Version: v2.0.3.0
Checksum defines the base class for generating the bar-code glyphs needed for adding checksum information.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Checksum
Public MustInherit Class Checksum
public ref class Checksum abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Checksum()()() | Initialises a new instance of Checksum class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
To implement a checksum class derived instances must implement the sole abstract method GetChecksum()()().
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum<(Of <(T>)>)


Checksum Constructor

Checksum Constructor
Namespaces ► Zen.Barcode ► Checksum ► Checksum()()()
Barcode Framework Version: v2.0.3.0
Initialises a new instance of Checksum class.
Declaration Syntax
C# Visual Basic Visual C++
protected Checksum()
Protected Sub New
protected:
Checksum()


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string.


GetChecksum Method (text)

GetChecksum Method (text)
Namespaces ► Zen.Barcode ► Checksum ► GetChecksum(String)
Barcode Framework Version: v2.0.3.0
Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetChecksum(
    string text
)
Public Overridable Function GetChecksum ( _
    text As String _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text
)
Parameters
text (String)
Text to be processed.
Return Value
A collection of BarcodeGlyph objects representing the checksum information.


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overridable Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
)
Parameters
text (String)
Text to be processed.
allowComposite (Boolean)
if set to true to allow use of composite glyphs.
Return Value
A collection of Glyph objects representing the checksum information.


Code11BarcodeDraw Class

Code11BarcodeDraw Class
Namespaces ► Zen.Barcode ► Code11BarcodeDraw
Barcode Framework Version: v2.0.3.0
Code11BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code11 barcodes with or without checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class Code11BarcodeDraw : BinaryPitchVaryLengthBarcodeDraw<Code11GlyphFactory, Code11Checksum>
Public Class Code11BarcodeDraw _
    Inherits BinaryPitchVaryLengthBarcodeDraw(Of Code11GlyphFactory, Code11Checksum)
public ref class Code11BarcodeDraw : public BinaryPitchVaryLengthBarcodeDraw<Code11GlyphFactory^, Code11Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code11BarcodeDraw(Code11GlyphFactory) | Initializes a new instance of the Code11BarcodeDraw class.
 | Code11BarcodeDraw(Code11Checksum) | Initializes a new instance of the Code11BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the barcode length. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Overridden. Gets the default inter-glyph spacing in pixels. (Overrides BarcodeDrawBase <(Of <( Code11GlyphFactory, Code11Checksum >)>).GetDefaultInterGlyphSpace(Int32, Int32).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( Code11GlyphFactory, Code11Checksum >)>).GetFullBarcode(String).)
 | GetGlyphEncodingBitCount(Glyph) | Overridden. Gets the glyph's encoding bit width. (Inherited from BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Overridden. Renders the specified glyph. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( Code11GlyphFactory, Code11Checksum >)>)
 |  |  | BinaryPitchBarcodeDraw <(Of <( Code11GlyphFactory, Code11Checksum >)>)
 |  |  |  | BinaryPitchVaryLengthBarcodeDraw <(Of <( Code11GlyphFactory, Code11Checksum >)>)
 |  |  |  |  | Code11BarcodeDraw


Code11BarcodeDraw Constructor

Code11BarcodeDraw Constructor
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► Code11BarcodeDraw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Code11BarcodeDraw(Code11GlyphFactory) | Initializes a new instance of the Code11BarcodeDraw class.
 | Code11BarcodeDraw(Code11Checksum) | Initializes a new instance of the Code11BarcodeDraw class.


Code11BarcodeDraw Constructor (checksum)

Code11BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► Code11BarcodeDraw(Code11Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code11BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code11BarcodeDraw(
    Code11Checksum checksum
)
Public Sub New ( _
    checksum As Code11Checksum _
)
public:
Code11BarcodeDraw(
    Code11Checksum^ checksum
)
Parameters
checksum (Code11Checksum)
The checksum.


Code11BarcodeDraw Constructor (factory)

Code11BarcodeDraw Constructor (factory)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► Code11BarcodeDraw(Code11GlyphFactory)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code11BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code11BarcodeDraw(
    Code11GlyphFactory factory
)
Public Sub New ( _
    factory As Code11GlyphFactory _
)
public:
Code11BarcodeDraw(
    Code11GlyphFactory^ factory
)
Parameters
factory (Code11GlyphFactory)
The factory.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the default inter-glyph spacing in pixels.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barMinWidth (Int32)

[Missing <param name="barMinWidth"/> documentation for "M:Zen.Barcode.Code11BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

barMaxWidth (Int32)

[Missing <param name="barMaxWidth"/> documentation for "M:Zen.Barcode.Code11BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code11BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


Code11Checksum Class

Code11Checksum Class
Namespaces ► Zen.Barcode ► Code11Checksum
Barcode Framework Version: v2.0.3.0
Code11Checksum implements a Code11 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code11Checksum : FactoryChecksum<Code11GlyphFactory>
Public NotInheritable Class Code11Checksum _
    Inherits FactoryChecksum(Of Code11GlyphFactory)
public ref class Code11Checksum sealed : public FactoryChecksum<Code11GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static Code11Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( Code11GlyphFactory >)>)
 |  |  | Code11Checksum


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► Code11Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overrides Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
The text.
allowComposite (Boolean)
if set to true [allow composite].
Return Value
A collection of Glyph objects that represent the checksum.


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code11Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static Code11Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code11Checksum Instance { get; }
Public Shared ReadOnly Property Instance As Code11Checksum
public:
static property Code11Checksum^ Instance {
    Code11Checksum^ get ();
}


Code11GlyphFactory Class

Code11GlyphFactory Class
Namespaces ► Zen.Barcode ► Code11GlyphFactory
Barcode Framework Version: v2.0.3.0
Code11GlyphFactory concrete implementation of GlyphFactory for providing Code 11 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code11GlyphFactory : GlyphFactory
Public NotInheritable Class Code11GlyphFactory _
    Inherits GlyphFactory
public ref class Code11GlyphFactory sealed : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code11GlyphFactory


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code11GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code11GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As Code11GlyphFactory
public:
static property Code11GlyphFactory^ Instance {
    Code11GlyphFactory^ get ();
}
Value
The instance.


Code128BarcodeDraw Class

Code128BarcodeDraw Class
Namespaces ► Zen.Barcode ► Code128BarcodeDraw
Barcode Framework Version: v2.0.3.0
Code128BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code128 barcodes with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class Code128BarcodeDraw : BarcodeDrawBase<Code128GlyphFactory, Code128Checksum>
Public Class Code128BarcodeDraw _
    Inherits BarcodeDrawBase(Of Code128GlyphFactory, Code128Checksum)
public ref class Code128BarcodeDraw : public BarcodeDrawBase<Code128GlyphFactory^, Code128Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code128BarcodeDraw(Code128Checksum) | Initializes a new instance of the Code128BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the length in pixels needed to render the specified barcode. (Overrides BarcodeDrawBase <(Of <( Code128GlyphFactory, Code128Checksum >)>).GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Gets the default amount of inter-glyph space to apply. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( Code128GlyphFactory, Code128Checksum >)>).GetFullBarcode(String).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( Code128GlyphFactory, Code128Checksum >)>)
 |  |  | Code128BarcodeDraw


Code128BarcodeDraw Constructor (checksum)

Code128BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► Code128BarcodeDraw(Code128Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code128BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code128BarcodeDraw(
    Code128Checksum checksum
)
Public Sub New ( _
    checksum As Code128Checksum _
)
public:
Code128BarcodeDraw(
    Code128Checksum^ checksum
)
Parameters
checksum (Code128Checksum)
The checksum.


GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)

GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the length in pixels needed to render the specified barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetBarcodeLength(
    Glyph[] barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetBarcodeLength ( _
    barcode As Glyph(), _
    interGlyphSpace As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetBarcodeLength(
    array<Glyph^>^ barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barcode (array< Glyph >[]()[])
Barcode glyphs to be analysed.
interGlyphSpace (Int32)
Amount of inter-glyph space.
barMinWidth (Int32)
Minimum bar width.
barMaxWidth (Int32)
Maximum bar width.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code128BarcodeDraw.GetBarcodeLength(Zen.Barcode.Glyph[],System.Int32,System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


Code128Checksum Class

Code128Checksum Class
Namespaces ► Zen.Barcode ► Code128Checksum
Barcode Framework Version: v2.0.3.0
Code128Checksum implements a Code128 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code128Checksum : FactoryChecksum<Code128GlyphFactory>
Public NotInheritable Class Code128Checksum _
    Inherits FactoryChecksum(Of Code128GlyphFactory)
public ref class Code128Checksum sealed : public FactoryChecksum<Code128GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static Code128Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( Code128GlyphFactory >)>)
 |  |  | Code128Checksum


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► Code128Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overrides Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
Text to be processed.
allowComposite (Boolean)
if set to true [allow composite].
Return Value
A collection of Glyph objects representing the checksum information.


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code128Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static Code128Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code128Checksum Instance { get; }
Public Shared ReadOnly Property Instance As Code128Checksum
public:
static property Code128Checksum^ Instance {
    Code128Checksum^ get ();
}


Code128Glyph Class

Code128Glyph Class
Namespaces ► Zen.Barcode ► Code128Glyph
Barcode Framework Version: v2.0.3.0
Code128Glyph extends MultisetGlyph by defining the three Code128 barcode sections.
Declaration Syntax
C# Visual Basic Visual C++
public class Code128Glyph : MultisetGlyph
Public Class Code128Glyph _
    Inherits MultisetGlyph
public ref class Code128Glyph : public MultisetGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code128Glyph(Char, Char, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Char, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Code128SpecialGlyph, Int16) | Initializes a new instance of the Code128Glyph class.
 | BitEncoding | Gets the bit encoding for this glyph. (Inherited from BarGlyph.)
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCharacterBySet(Int32) | Gets the character representation for the specified character set. (Inherited from MultisetGlyph.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSpecialBySet(Int32) | Gets the Code128SpecialGlyph glyph by set.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Sets | Gets an Int32 that represents the number of character sets encoded in this glyph. (Inherited from MultisetGlyph.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | MultisetGlyph
 |  |  |  | Code128Glyph


Code128Glyph Constructor

Code128Glyph Constructor
Namespaces ► Zen.Barcode ► Code128Glyph ► Code128Glyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Code128Glyph(Char, Char, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Char, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Char, Int16) | Initializes a new instance of the Code128Glyph class.
 | Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Code128SpecialGlyph, Int16) | Initializes a new instance of the Code128Glyph class.


Code128Glyph Constructor (first, second, third, bitEncoding)

Code128Glyph Constructor (first, second, third, bitEncoding)
Namespaces ► Zen.Barcode ► Code128Glyph ► Code128Glyph(Char, Char, Char, Int16)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code128Glyph class.
Declaration Syntax
C# Visual Basic Visual C++
public Code128Glyph(
    char first,
    char second,
    char third,
    short bitEncoding
)
Public Sub New ( _
    first As Char, _
    second As Char, _
    third As Char, _
    bitEncoding As Short _
)
public:
Code128Glyph(
    wchar_t first,
    wchar_t second,
    wchar_t third,
    short bitEncoding
)
Parameters
first (Char)
The first set character.
second (Char)
The second set character.
third (Char)
The third set character.
bitEncoding (Int16)
The glyph bit encoding.


Code128Glyph Constructor (first, second, third, bitEncoding)

Code128Glyph Constructor (first, second, third, bitEncoding)
Namespaces ► Zen.Barcode ► Code128Glyph ► Code128Glyph(Code128SpecialGlyph, Char, Char, Int16)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code128Glyph class.
Declaration Syntax
C# Visual Basic Visual C++
public Code128Glyph(
    Code128SpecialGlyph first,
    char second,
    char third,
    short bitEncoding
)
Public Sub New ( _
    first As Code128SpecialGlyph, _
    second As Char, _
    third As Char, _
    bitEncoding As Short _
)
public:
Code128Glyph(
    Code128SpecialGlyph first,
    wchar_t second,
    wchar_t third,
    short bitEncoding
)
Parameters
first (Code128SpecialGlyph)
A Code128SpecialGlyph representing the first set object.
second (Char)
The second set character.
third (Char)
The third set character.
bitEncoding (Int16)
The glyph bit encoding.


Code128Glyph Constructor (first, second, third, bitEncoding)

Code128Glyph Constructor (first, second, third, bitEncoding)
Namespaces ► Zen.Barcode ► Code128Glyph ► Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Char, Int16)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code128Glyph class.
Declaration Syntax
C# Visual Basic Visual C++
public Code128Glyph(
    Code128SpecialGlyph first,
    Code128SpecialGlyph second,
    char third,
    short bitEncoding
)
Public Sub New ( _
    first As Code128SpecialGlyph, _
    second As Code128SpecialGlyph, _
    third As Char, _
    bitEncoding As Short _
)
public:
Code128Glyph(
    Code128SpecialGlyph first,
    Code128SpecialGlyph second,
    wchar_t third,
    short bitEncoding
)
Parameters
first (Code128SpecialGlyph)
A Code128SpecialGlyph representing the first set object.
second (Code128SpecialGlyph)
A Code128SpecialGlyph representing the second set object.
third (Char)
The third set character.
bitEncoding (Int16)
The glyph bit encoding.


Code128Glyph Constructor (first, second, third, bitEncoding)

Code128Glyph Constructor (first, second, third, bitEncoding)
Namespaces ► Zen.Barcode ► Code128Glyph ► Code128Glyph(Code128SpecialGlyph, Code128SpecialGlyph, Code128SpecialGlyph, Int16)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code128Glyph class.
Declaration Syntax
C# Visual Basic Visual C++
public Code128Glyph(
    Code128SpecialGlyph first,
    Code128SpecialGlyph second,
    Code128SpecialGlyph third,
    short bitEncoding
)
Public Sub New ( _
    first As Code128SpecialGlyph, _
    second As Code128SpecialGlyph, _
    third As Code128SpecialGlyph, _
    bitEncoding As Short _
)
public:
Code128Glyph(
    Code128SpecialGlyph first,
    Code128SpecialGlyph second,
    Code128SpecialGlyph third,
    short bitEncoding
)
Parameters
first (Code128SpecialGlyph)
A Code128SpecialGlyph representing the first set object.
second (Code128SpecialGlyph)
A Code128SpecialGlyph representing the second set object.
third (Code128SpecialGlyph)
A Code128SpecialGlyph representing the third set object.
bitEncoding (Int16)
The glyph bit encoding.


GetSpecialBySet Method (set)

GetSpecialBySet Method (set)
Namespaces ► Zen.Barcode ► Code128Glyph ► GetSpecialBySet(Int32)
Barcode Framework Version: v2.0.3.0
Gets the Code128SpecialGlyph glyph by set.
Declaration Syntax
C# Visual Basic Visual C++
public Code128SpecialGlyph GetSpecialBySet(
    int set
)
Public Function GetSpecialBySet ( _
    set As Integer _
) As Code128SpecialGlyph
public:
Code128SpecialGlyph GetSpecialBySet(
    int set
)
Parameters
set (Int32)
The set.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code128Glyph.GetSpecialBySet(System.Int32)]


Code128GlyphFactory Class

Code128GlyphFactory Class
Namespaces ► Zen.Barcode ► Code128GlyphFactory
Barcode Framework Version: v2.0.3.0
Code128GlyphFactory concrete implementation of GlyphFactory for providing Code 128 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public class Code128GlyphFactory : GlyphFactory
Public Class Code128GlyphFactory _
    Inherits GlyphFactory
public ref class Code128GlyphFactory : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetCompositeGlyphs()()().)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs()()() | Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetGlyphs()()().)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code128GlyphFactory


GetCompositeGlyphs Method

GetCompositeGlyphs Method
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► GetCompositeGlyphs()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected override CompositeGlyph[] GetCompositeGlyphs()
Protected Overrides Function GetCompositeGlyphs As CompositeGlyph()
protected:
virtual array<CompositeGlyph^>^ GetCompositeGlyphs() override
Return Value
The full collection of CompositeGlyph objects associated with this symbology.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs()()() | Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetGlyphs()()().)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected override BarGlyph[] GetGlyphs()
Protected Overrides Function GetGlyphs As BarGlyph()
protected:
virtual array<BarGlyph^>^ GetGlyphs() override
Return Value
The full collection of BarGlyph objects associated with this symbology.


GetGlyphs Method (text, allowComposite)

GetGlyphs Method (text, allowComposite)
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► GetGlyphs(String, Boolean)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetGlyphs(
    string text,
    bool allowComposite
)
Public Overrides Function GetGlyphs ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
A String containing text to be translated.
allowComposite (Boolean)
if set to true to allow composite glyphs to be returned.
Return Value
A collection of Glyph objects.


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code128GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As Code128GlyphFactory
public:
static property Code128GlyphFactory^ Instance {
    Code128GlyphFactory^ get ();
}
Value
The instance.


Code128SpecialGlyph Enumeration

Code128SpecialGlyph Enumeration
Namespaces ► Zen.Barcode ► Code128SpecialGlyph
Barcode Framework Version: v2.0.3.0
Defines special control codes which have no character representation.
Declaration Syntax
C# Visual Basic Visual C++
public enum Code128SpecialGlyph
Public Enumeration Code128SpecialGlyph
public enum class Code128SpecialGlyph
Members
Member | Description
None | Not special
StartSetA | Start of character set A
StartSetB | Start of character set B
StartSetC | Start of character set C
SwitchToA | Switch to character set A
SwitchToB | Switch to character set B
SwitchToC | Switch to character set C
Func1 | Function 1
Func2 | Function 2
Func3 | Function 3
Func4 | Function 4
Shift | Shift
Stop | Stop
Terminal | Terminal


Code25BarcodeDraw Class

Code25BarcodeDraw Class
Namespaces ► Zen.Barcode ► Code25BarcodeDraw
Barcode Framework Version: v2.0.3.0
Code25StandardBarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code25Standard barcodes with or without checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class Code25BarcodeDraw : BarcodeDrawBase<Code25GlyphFactory, Code25Checksum>
Public Class Code25BarcodeDraw _
    Inherits BarcodeDrawBase(Of Code25GlyphFactory, Code25Checksum)
public ref class Code25BarcodeDraw : public BarcodeDrawBase<Code25GlyphFactory^, Code25Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code25BarcodeDraw(Code25GlyphFactory) | Initializes a new instance of the Code25BarcodeDraw class.
 | Code25BarcodeDraw(Code25Checksum) | Initializes a new instance of the Code25BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Gets the length in pixels needed to render the specified barcode. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Overridden. Gets the default inter-glyph spacing in pixels. (Overrides BarcodeDrawBase <(Of <( Code25GlyphFactory, Code25Checksum >)>).GetDefaultInterGlyphSpace(Int32, Int32).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( Code25GlyphFactory, Code25Checksum >)>).GetFullBarcode(String).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( Code25GlyphFactory, Code25Checksum >)>)
 |  |  | Code25BarcodeDraw


Code25BarcodeDraw Constructor

Code25BarcodeDraw Constructor
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► Code25BarcodeDraw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Code25BarcodeDraw(Code25GlyphFactory) | Initializes a new instance of the Code25BarcodeDraw class.
 | Code25BarcodeDraw(Code25Checksum) | Initializes a new instance of the Code25BarcodeDraw class.


Code25BarcodeDraw Constructor (checksum)

Code25BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► Code25BarcodeDraw(Code25Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code25BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code25BarcodeDraw(
    Code25Checksum checksum
)
Public Sub New ( _
    checksum As Code25Checksum _
)
public:
Code25BarcodeDraw(
    Code25Checksum^ checksum
)
Parameters
checksum (Code25Checksum)
The checksum.


Code25BarcodeDraw Constructor (factory)

Code25BarcodeDraw Constructor (factory)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► Code25BarcodeDraw(Code25GlyphFactory)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code25BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code25BarcodeDraw(
    Code25GlyphFactory factory
)
Public Sub New ( _
    factory As Code25GlyphFactory _
)
public:
Code25BarcodeDraw(
    Code25GlyphFactory^ factory
)
Parameters
factory (Code25GlyphFactory)
The factory.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the default inter-glyph spacing in pixels.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barMinWidth (Int32)

[Missing <param name="barMinWidth"/> documentation for "M:Zen.Barcode.Code25BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

barMaxWidth (Int32)

[Missing <param name="barMaxWidth"/> documentation for "M:Zen.Barcode.Code25BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code25BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


Code25Checksum Class

Code25Checksum Class
Namespaces ► Zen.Barcode ► Code25Checksum
Barcode Framework Version: v2.0.3.0
Code25Checksum implements a Code25Standard checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code25Checksum : FactoryChecksum<Code25GlyphFactory>
Public NotInheritable Class Code25Checksum _
    Inherits FactoryChecksum(Of Code25GlyphFactory)
public ref class Code25Checksum sealed : public FactoryChecksum<Code25GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterleavedInstance | Gets the static Code25Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StandardInstance | Gets the static Code25Checksum object instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( Code25GlyphFactory >)>)
 |  |  | Code25Checksum


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► Code25Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overrides Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
The text.
allowComposite (Boolean)
if set to true [allow composite].
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code25Checksum.GetChecksum(System.String,System.Boolean)]


InterleavedInstance Property

InterleavedInstance Property
Namespaces ► Zen.Barcode ► Code25Checksum ► InterleavedInstance
Barcode Framework Version: v2.0.3.0
Gets the static Code25Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25Checksum InterleavedInstance { get; }
Public Shared ReadOnly Property InterleavedInstance As Code25Checksum
public:
static property Code25Checksum^ InterleavedInstance {
    Code25Checksum^ get ();
}


StandardInstance Property

StandardInstance Property
Namespaces ► Zen.Barcode ► Code25Checksum ► StandardInstance
Barcode Framework Version: v2.0.3.0
Gets the static Code25Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25Checksum StandardInstance { get; }
Public Shared ReadOnly Property StandardInstance As Code25Checksum
public:
static property Code25Checksum^ StandardInstance {
    Code25Checksum^ get ();
}


Code25GlyphFactory Class

Code25GlyphFactory Class
Namespaces ► Zen.Barcode ► Code25GlyphFactory
Barcode Framework Version: v2.0.3.0
Code25GlyphFactory base class for all code 25 GlyphFactory objects.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Code25GlyphFactory : GlyphFactory
Public MustInherit Class Code25GlyphFactory _
    Inherits GlyphFactory
public ref class Code25GlyphFactory abstract : public GlyphFactory
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code25GlyphFactory()()() | Initializes a new instance of the Code25GlyphFactory class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetCompositeGlyphs()()().)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterleavedInstance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StandardInstance | Gets the global instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code25GlyphFactory
 |  |  | Code25InterleavedGlyphFactory
 |  |  | Code25StandardGlyphFactory


Code25GlyphFactory Constructor

Code25GlyphFactory Constructor
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► Code25GlyphFactory()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code25GlyphFactory class.
Declaration Syntax
C# Visual Basic Visual C++
protected Code25GlyphFactory()
Protected Sub New
protected:
Code25GlyphFactory()


GetCompositeGlyphs Method

GetCompositeGlyphs Method
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► GetCompositeGlyphs()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected override CompositeGlyph[] GetCompositeGlyphs()
Protected Overrides Function GetCompositeGlyphs As CompositeGlyph()
protected:
virtual array<CompositeGlyph^>^ GetCompositeGlyphs() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code25GlyphFactory.GetCompositeGlyphs]


InterleavedInstance Property

InterleavedInstance Property
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► InterleavedInstance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25InterleavedGlyphFactory InterleavedInstance { get; }
Public Shared ReadOnly Property InterleavedInstance As Code25InterleavedGlyphFactory
public:
static property Code25InterleavedGlyphFactory^ InterleavedInstance {
    Code25InterleavedGlyphFactory^ get ();
}
Value
The instance.


StandardInstance Property

StandardInstance Property
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► StandardInstance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code25StandardGlyphFactory StandardInstance { get; }
Public Shared ReadOnly Property StandardInstance As Code25StandardGlyphFactory
public:
static property Code25StandardGlyphFactory^ StandardInstance {
    Code25StandardGlyphFactory^ get ();
}
Value
The instance.


Code25InterleavedGlyphFactory Class

Code25InterleavedGlyphFactory Class
Namespaces ► Zen.Barcode ► Code25InterleavedGlyphFactory
Barcode Framework Version: v2.0.3.0
Code25InterleavedGlyphFactory concrete implementation of GlyphFactory for providing Code 25 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code25InterleavedGlyphFactory : Code25GlyphFactory
Public NotInheritable Class Code25InterleavedGlyphFactory _
    Inherits Code25GlyphFactory
public ref class Code25InterleavedGlyphFactory sealed : public Code25GlyphFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Code25InterleavedGlyphFactory()()() | Initializes a new instance of the Code25InterleavedGlyphFactory class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from Code25GlyphFactory.)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code25GlyphFactory
 |  |  | Code25InterleavedGlyphFactory


Code25InterleavedGlyphFactory Constructor

Code25InterleavedGlyphFactory Constructor
Namespaces ► Zen.Barcode ► Code25InterleavedGlyphFactory ► Code25InterleavedGlyphFactory()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code25InterleavedGlyphFactory class.
Declaration Syntax
C# Visual Basic Visual C++
public Code25InterleavedGlyphFactory()
Public Sub New
public:
Code25InterleavedGlyphFactory()


Code25StandardGlyphFactory Class

Code25StandardGlyphFactory Class
Namespaces ► Zen.Barcode ► Code25StandardGlyphFactory
Barcode Framework Version: v2.0.3.0
Code25StandardGlyphFactory concrete implementation of GlyphFactory for providing Code 25 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code25StandardGlyphFactory : Code25GlyphFactory
Public NotInheritable Class Code25StandardGlyphFactory _
    Inherits Code25GlyphFactory
public ref class Code25StandardGlyphFactory sealed : public Code25GlyphFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Code25StandardGlyphFactory()()() | Initializes a new instance of the Code25StandardGlyphFactory class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from Code25GlyphFactory.)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code25GlyphFactory
 |  |  | Code25StandardGlyphFactory


Code25StandardGlyphFactory Constructor

Code25StandardGlyphFactory Constructor
Namespaces ► Zen.Barcode ► Code25StandardGlyphFactory ► Code25StandardGlyphFactory()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code25StandardGlyphFactory class.
Declaration Syntax
C# Visual Basic Visual C++
public Code25StandardGlyphFactory()
Public Sub New
public:
Code25StandardGlyphFactory()


Code39BarcodeDraw Class

Code39BarcodeDraw Class
Namespaces ► Zen.Barcode ► Code39BarcodeDraw
Barcode Framework Version: v2.0.3.0
Code39BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code39 barcodes with or without checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class Code39BarcodeDraw : BinaryPitchBarcodeDraw<Code39GlyphFactory, Code39Checksum>
Public Class Code39BarcodeDraw _
    Inherits BinaryPitchBarcodeDraw(Of Code39GlyphFactory, Code39Checksum)
public ref class Code39BarcodeDraw : public BinaryPitchBarcodeDraw<Code39GlyphFactory^, Code39Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code39BarcodeDraw(Code39GlyphFactory) | Initializes a new instance of the Code39BarcodeDraw class.
 | Code39BarcodeDraw(Code39Checksum) | Initializes a new instance of the Code39BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the barcode length. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Overridden. Gets the default inter-glyph spacing in pixels. (Overrides BarcodeDrawBase <(Of <( Code39GlyphFactory, Code39Checksum >)>).GetDefaultInterGlyphSpace(Int32, Int32).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( Code39GlyphFactory, Code39Checksum >)>).GetFullBarcode(String).)
 | GetGlyphEncodingBitCount(Glyph) | Gets the glyph's encoding bit width. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Overridden. Renders the specified glyph. (Inherited from BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( Code39GlyphFactory, Code39Checksum >)>)
 |  |  | BinaryPitchBarcodeDraw <(Of <( Code39GlyphFactory, Code39Checksum >)>)
 |  |  |  | Code39BarcodeDraw


Code39BarcodeDraw Constructor

Code39BarcodeDraw Constructor
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► Code39BarcodeDraw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Code39BarcodeDraw(Code39GlyphFactory) | Initializes a new instance of the Code39BarcodeDraw class.
 | Code39BarcodeDraw(Code39Checksum) | Initializes a new instance of the Code39BarcodeDraw class.


Code39BarcodeDraw Constructor (checksum)

Code39BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► Code39BarcodeDraw(Code39Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code39BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code39BarcodeDraw(
    Code39Checksum checksum
)
Public Sub New ( _
    checksum As Code39Checksum _
)
public:
Code39BarcodeDraw(
    Code39Checksum^ checksum
)
Parameters
checksum (Code39Checksum)
The checksum.


Code39BarcodeDraw Constructor (factory)

Code39BarcodeDraw Constructor (factory)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► Code39BarcodeDraw(Code39GlyphFactory)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code39BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code39BarcodeDraw(
    Code39GlyphFactory factory
)
Public Sub New ( _
    factory As Code39GlyphFactory _
)
public:
Code39BarcodeDraw(
    Code39GlyphFactory^ factory
)
Parameters
factory (Code39GlyphFactory)
The factory.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the default inter-glyph spacing in pixels.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barMinWidth (Int32)

[Missing <param name="barMinWidth"/> documentation for "M:Zen.Barcode.Code39BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

barMaxWidth (Int32)

[Missing <param name="barMaxWidth"/> documentation for "M:Zen.Barcode.Code39BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code39BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


Code39Checksum Class

Code39Checksum Class
Namespaces ► Zen.Barcode ► Code39Checksum
Barcode Framework Version: v2.0.3.0
Code39Checksum implements a Code39 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code39Checksum : FactoryChecksum<Code39GlyphFactory>
Public NotInheritable Class Code39Checksum _
    Inherits FactoryChecksum(Of Code39GlyphFactory)
public ref class Code39Checksum sealed : public FactoryChecksum<Code39GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String).)
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static Code39Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( Code39GlyphFactory >)>)
 |  |  | Code39Checksum


GetChecksum Method (text)

GetChecksum Method (text)
Namespaces ► Zen.Barcode ► Code39Checksum ► GetChecksum(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text
)
Public Overrides Function GetChecksum ( _
    text As String _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text
) override
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Code39Checksum.GetChecksum(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code39Checksum.GetChecksum(System.String)]


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code39Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static Code39Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code39Checksum Instance { get; }
Public Shared ReadOnly Property Instance As Code39Checksum
public:
static property Code39Checksum^ Instance {
    Code39Checksum^ get ();
}


Code39GlyphFactory Class

Code39GlyphFactory Class
Namespaces ► Zen.Barcode ► Code39GlyphFactory
Barcode Framework Version: v2.0.3.0
Code39GlyphFactory concrete implementation of GlyphFactory for providing Code 39 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code39GlyphFactory : GlyphFactory
Public NotInheritable Class Code39GlyphFactory _
    Inherits GlyphFactory
public ref class Code39GlyphFactory sealed : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code39GlyphFactory


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code39GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code39GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As Code39GlyphFactory
public:
static property Code39GlyphFactory^ Instance {
    Code39GlyphFactory^ get ();
}
Value
The instance.


Code93BarcodeDraw Class

Code93BarcodeDraw Class
Namespaces ► Zen.Barcode ► Code93BarcodeDraw
Barcode Framework Version: v2.0.3.0
Code93BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code93 barcodes with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class Code93BarcodeDraw : BarcodeDrawBase<Code93GlyphFactory, Code93Checksum>
Public Class Code93BarcodeDraw _
    Inherits BarcodeDrawBase(Of Code93GlyphFactory, Code93Checksum)
public ref class Code93BarcodeDraw : public BarcodeDrawBase<Code93GlyphFactory^, Code93Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code93BarcodeDraw(Code93Checksum) | Initializes a new instance of the Code93BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Overridden. Gets the length in pixels needed to render the specified barcode. (Overrides BarcodeDrawBase <(Of <( Code93GlyphFactory, Code93Checksum >)>).GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Gets the default amount of inter-glyph space to apply. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( Code93GlyphFactory, Code93Checksum >)>).GetFullBarcode(String).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( Code93GlyphFactory, Code93Checksum >)>)
 |  |  | Code93BarcodeDraw


Code93BarcodeDraw Constructor (checksum)

Code93BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► Code93BarcodeDraw(Code93Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the Code93BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public Code93BarcodeDraw(
    Code93Checksum checksum
)
Public Sub New ( _
    checksum As Code93Checksum _
)
public:
Code93BarcodeDraw(
    Code93Checksum^ checksum
)
Parameters
checksum (Code93Checksum)
The checksum.


GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)

GetBarcodeLength Method (barcode, interGlyphSpace, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the length in pixels needed to render the specified barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetBarcodeLength(
    Glyph[] barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetBarcodeLength ( _
    barcode As Glyph(), _
    interGlyphSpace As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetBarcodeLength(
    array<Glyph^>^ barcode,
    int interGlyphSpace,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barcode (array< Glyph >[]()[])
Barcode glyphs to be analysed.
interGlyphSpace (Int32)
Amount of inter-glyph space.
barMinWidth (Int32)
Minimum barcode width.
barMaxWidth (Int32)
Maximum barcode width.
Return Value
The barcode width in pixels.
Remarks
Currently this method does not account for any "quiet space" around the barcode as dictated by each symbology standard.


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


Code93Checksum Class

Code93Checksum Class
Namespaces ► Zen.Barcode ► Code93Checksum
Barcode Framework Version: v2.0.3.0
Code93Checksum implements a Code93 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Code93Checksum : FactoryChecksum<Code93GlyphFactory>
Public NotInheritable Class Code93Checksum _
    Inherits FactoryChecksum(Of Code93GlyphFactory)
public ref class Code93Checksum sealed : public FactoryChecksum<Code93GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String).)
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static Code93Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( Code93GlyphFactory >)>)
 |  |  | Code93Checksum


GetChecksum Method (text)

GetChecksum Method (text)
Namespaces ► Zen.Barcode ► Code93Checksum ► GetChecksum(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text
)
Public Overrides Function GetChecksum ( _
    text As String _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text
) override
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Code93Checksum.GetChecksum(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code93Checksum.GetChecksum(System.String)]


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code93Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static Code93Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code93Checksum Instance { get; }
Public Shared ReadOnly Property Instance As Code93Checksum
public:
static property Code93Checksum^ Instance {
    Code93Checksum^ get ();
}


Code93GlyphFactory Class

Code93GlyphFactory Class
Namespaces ► Zen.Barcode ► Code93GlyphFactory
Barcode Framework Version: v2.0.3.0
Code93GlyphFactory concrete implementation of GlyphFactory for providing Code 93 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public class Code93GlyphFactory : GlyphFactory
Public Class Code93GlyphFactory _
    Inherits GlyphFactory
public ref class Code93GlyphFactory : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetCompositeGlyphs()()().)
 | GetGlyphs()()() | Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetGlyphs()()().)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code93GlyphFactory


GetCompositeGlyphs Method

GetCompositeGlyphs Method
Namespaces ► Zen.Barcode ► Code93GlyphFactory ► GetCompositeGlyphs()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected override CompositeGlyph[] GetCompositeGlyphs()
Protected Overrides Function GetCompositeGlyphs As CompositeGlyph()
protected:
virtual array<CompositeGlyph^>^ GetCompositeGlyphs() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code93GlyphFactory.GetCompositeGlyphs]


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code93GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected override BarGlyph[] GetGlyphs()
Protected Overrides Function GetGlyphs As BarGlyph()
protected:
virtual array<BarGlyph^>^ GetGlyphs() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Code93GlyphFactory.GetGlyphs]


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► Code93GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static Code93GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As Code93GlyphFactory
public:
static property Code93GlyphFactory^ Instance {
    Code93GlyphFactory^ get ();
}
Value
The instance.


CodeEan13BarcodeDraw Class

CodeEan13BarcodeDraw Class
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw
Barcode Framework Version: v2.0.3.0
CodeEan13BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code EAN 13 barcodes with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class CodeEan13BarcodeDraw : BarcodeDrawBase<CodeEan13GlyphFactory, CodeEan13Checksum>
Public Class CodeEan13BarcodeDraw _
    Inherits BarcodeDrawBase(Of CodeEan13GlyphFactory, CodeEan13Checksum)
public ref class CodeEan13BarcodeDraw : public BarcodeDrawBase<CodeEan13GlyphFactory^, CodeEan13Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeEan13BarcodeDraw(CodeEan13Checksum) | Initializes a new instance of the CodeEan13BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Gets the length in pixels needed to render the specified barcode. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Overridden. Gets the default inter-glyph spacing in pixels. (Overrides BarcodeDrawBase <(Of <( CodeEan13GlyphFactory, CodeEan13Checksum >)>).GetDefaultInterGlyphSpace(Int32, Int32).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( CodeEan13GlyphFactory, CodeEan13Checksum >)>).GetFullBarcode(String).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Overrides BarcodeDrawBase <(Of <( CodeEan13GlyphFactory, CodeEan13Checksum >)>).GetGlyphHeight(Glyph, Int32, Int32).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( CodeEan13GlyphFactory, CodeEan13Checksum >)>)
 |  |  | CodeEan13BarcodeDraw


CodeEan13BarcodeDraw Constructor (checksum)

CodeEan13BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► CodeEan13BarcodeDraw(CodeEan13Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the CodeEan13BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public CodeEan13BarcodeDraw(
    CodeEan13Checksum checksum
)
Public Sub New ( _
    checksum As CodeEan13Checksum _
)
public:
CodeEan13BarcodeDraw(
    CodeEan13Checksum^ checksum
)
Parameters
checksum (CodeEan13Checksum)
The checksum.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the default inter-glyph spacing in pixels.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barMinWidth (Int32)

[Missing <param name="barMinWidth"/> documentation for "M:Zen.Barcode.CodeEan13BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

barMaxWidth (Int32)

[Missing <param name="barMaxWidth"/> documentation for "M:Zen.Barcode.CodeEan13BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan13BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)

GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► GetGlyphHeight(Glyph, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Gets the height of the glyph.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetGlyphHeight(
    Glyph glyph,
    int barMinHeight,
    int barMaxHeight
)
Protected Overrides Function GetGlyphHeight ( _
    glyph As Glyph, _
    barMinHeight As Integer, _
    barMaxHeight As Integer _
) As Integer
protected:
virtual int GetGlyphHeight(
    Glyph^ glyph,
    int barMinHeight,
    int barMaxHeight
) override
Parameters
glyph (Glyph)
The glyph.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan13BarcodeDraw.GetGlyphHeight(Zen.Barcode.Glyph,System.Int32,System.Int32)]

Remarks
For EAN 13 the only full height glyphs are start/stop/seperator glyphs.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


CodeEan13Checksum Class

CodeEan13Checksum Class
Namespaces ► Zen.Barcode ► CodeEan13Checksum
Barcode Framework Version: v2.0.3.0
CodeEan13Checksum implements a Code EAN-13 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CodeEan13Checksum : FactoryChecksum<CodeEan13GlyphFactory>
Public NotInheritable Class CodeEan13Checksum _
    Inherits FactoryChecksum(Of CodeEan13GlyphFactory)
public ref class CodeEan13Checksum sealed : public FactoryChecksum<CodeEan13GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetChecksumChar(String) | Gets the checksum char.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static CodeEan13Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( CodeEan13GlyphFactory >)>)
 |  |  | CodeEan13Checksum


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► CodeEan13Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overrides Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
Text to be processed.
allowComposite (Boolean)
if set to true [allow composite].
Return Value
A collection of Glyph objects representing the checksum information.


GetChecksumChar Method (text)

GetChecksumChar Method (text)
Namespaces ► Zen.Barcode ► CodeEan13Checksum ► GetChecksumChar(String)
Barcode Framework Version: v2.0.3.0
Gets the checksum char.
Declaration Syntax
C# Visual Basic Visual C++
public char GetChecksumChar(
    string text
)
Public Function GetChecksumChar ( _
    text As String _
) As Char
public:
wchar_t GetChecksumChar(
    String^ text
)
Parameters
text (String)
The text.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan13Checksum.GetChecksumChar(System.String)]


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► CodeEan13Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static CodeEan13Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan13Checksum Instance { get; }
Public Shared ReadOnly Property Instance As CodeEan13Checksum
public:
static property CodeEan13Checksum^ Instance {
    CodeEan13Checksum^ get ();
}


CodeEan13GlyphFactory Class

CodeEan13GlyphFactory Class
Namespaces ► Zen.Barcode ► CodeEan13GlyphFactory
Barcode Framework Version: v2.0.3.0
CodeEan13GlyphFactory concrete implementation of GlyphFactory for providing Code EAN 13 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CodeEan13GlyphFactory : GlyphFactory
Public NotInheritable Class CodeEan13GlyphFactory _
    Inherits GlyphFactory
public ref class CodeEan13GlyphFactory sealed : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | CodeEan13GlyphFactory


GetGlyphs Method (text, allowComposite)

GetGlyphs Method (text, allowComposite)
Namespaces ► Zen.Barcode ► CodeEan13GlyphFactory ► GetGlyphs(String, Boolean)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetGlyphs(
    string text,
    bool allowComposite
)
Public Overrides Function GetGlyphs ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
The text.
allowComposite (Boolean)
if set to true [allow composite].
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan13GlyphFactory.GetGlyphs(System.String,System.Boolean)]

Remarks
For this method to work as expected the barcode text should not include the first EAN13 digit (this is used to derive parity and is not rendered) but should include the checksum digit.


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► CodeEan13GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan13GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As CodeEan13GlyphFactory
public:
static property CodeEan13GlyphFactory^ Instance {
    CodeEan13GlyphFactory^ get ();
}
Value
The instance.


CodeEan8BarcodeDraw Class

CodeEan8BarcodeDraw Class
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw
Barcode Framework Version: v2.0.3.0
CodeEan8BarcodeDraw is a type-safe extension of BarcodeDraw that can render complete Code EAN-8 barcodes with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public class CodeEan8BarcodeDraw : BarcodeDrawBase<CodeEan8GlyphFactory, CodeEan8Checksum>
Public Class CodeEan8BarcodeDraw _
    Inherits BarcodeDrawBase(Of CodeEan8GlyphFactory, CodeEan8Checksum)
public ref class CodeEan8BarcodeDraw : public BarcodeDrawBase<CodeEan8GlyphFactory^, CodeEan8Checksum^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeEan8BarcodeDraw(CodeEan8Checksum) | Initializes a new instance of the CodeEan8BarcodeDraw class.
 | Checksum | Gets the TChecksum checksum object. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | EncodingBitCount | Gets the number of bits used for a glyph encoding. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the TGlyphFactory glyph factory. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcodeInterGlyphLength(array<Glyph>[]()[], Int32) | Gets the total width in pixels for the specified barcode glyphs incorporating the specified inter-glyph spacing. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetBarcodeLength(array<Glyph>[]()[], Int32, Int32, Int32) | Gets the length in pixels needed to render the specified barcode. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetDefaultInterGlyphSpace(Int32, Int32) | Overridden. Gets the default inter-glyph spacing in pixels. (Overrides BarcodeDrawBase <(Of <( CodeEan8GlyphFactory, CodeEan8Checksum >)>).GetDefaultInterGlyphSpace(Int32, Int32).)
 | GetDefaultMetrics(Int32) | Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetEncodingBitCount(Glyph) | Gets the glyph's barcode encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | GetFullBarcode(String) | Overridden. Gets the glyphs needed to render a full barcode. (Overrides BarcodeDrawBase <(Of <( CodeEan8GlyphFactory, CodeEan8Checksum >)>).GetFullBarcode(String).)
 | GetGlyphHeight(Glyph, Int32, Int32) | Gets the height of the glyph. (Overrides BarcodeDrawBase <(Of <( CodeEan8GlyphFactory, CodeEan8Checksum >)>).GetGlyphHeight(Glyph, Int32, Int32).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidthBitCount(Glyph) | Gets the glyph's width encoding bit count. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the specified bar-code to the specified graphics port. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBar(BarGlyph, Graphics, Rectangle, Int32%, Int32, Int32, Int32) | Renders the bar-code glyph. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | RenderBars(array<Glyph>[]()[], Graphics, Rectangle, Int32, Int32, Int32, Int32) | Renders the barcode bars. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WidthBitCount | Gets the number of bits used to encode the glyph width information. (Inherited from BarcodeDrawBase<(Of <(TGlyphFactory, TChecksum>)>).)
Remarks
EAN-8 reuses the EAN-13 checksum object since the algorithm is exactly the same however a different glyph factory is used due to the differing mechanisms used to return gyph arrays.
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | BarcodeDrawBase <(Of <( CodeEan8GlyphFactory, CodeEan8Checksum >)>)
 |  |  | CodeEan8BarcodeDraw


CodeEan8BarcodeDraw Constructor (checksum)

CodeEan8BarcodeDraw Constructor (checksum)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► CodeEan8BarcodeDraw(CodeEan8Checksum)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the CodeEan8BarcodeDraw class.
Declaration Syntax
C# Visual Basic Visual C++
public CodeEan8BarcodeDraw(
    CodeEan8Checksum checksum
)
Public Sub New ( _
    checksum As CodeEan8Checksum _
)
public:
CodeEan8BarcodeDraw(
    CodeEan8Checksum^ checksum
)
Parameters
checksum (CodeEan8Checksum)
The checksum.


GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)

GetDefaultInterGlyphSpace Method (barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► GetDefaultInterGlyphSpace(Int32, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the default inter-glyph spacing in pixels.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
)
Protected Overrides Function GetDefaultInterGlyphSpace ( _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Integer
protected:
virtual int GetDefaultInterGlyphSpace(
    int barMinWidth,
    int barMaxWidth
) override
Parameters
barMinWidth (Int32)

[Missing <param name="barMinWidth"/> documentation for "M:Zen.Barcode.CodeEan8BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

barMaxWidth (Int32)

[Missing <param name="barMaxWidth"/> documentation for "M:Zen.Barcode.CodeEan8BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan8BarcodeDraw.GetDefaultInterGlyphSpace(System.Int32,System.Int32)]


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetFullBarcode Method (text)

GetFullBarcode Method (text)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► GetFullBarcode(String)
Barcode Framework Version: v2.0.3.0
Overridden. Gets the glyphs needed to render a full barcode.
Declaration Syntax
C# Visual Basic Visual C++
protected override Glyph[] GetFullBarcode(
    string text
)
Protected Overrides Function GetFullBarcode ( _
    text As String _
) As Glyph()
protected:
virtual array<Glyph^>^ GetFullBarcode(
    String^ text
) override
Parameters
text (String)
Text to convert into bar-code.
Return Value
A collection of Glyph objects.


GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)

GetGlyphHeight Method (glyph, barMinHeight, barMaxHeight)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► GetGlyphHeight(Glyph, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Gets the height of the glyph.
Declaration Syntax
C# Visual Basic Visual C++
protected override int GetGlyphHeight(
    Glyph glyph,
    int barMinHeight,
    int barMaxHeight
)
Protected Overrides Function GetGlyphHeight ( _
    glyph As Glyph, _
    barMinHeight As Integer, _
    barMaxHeight As Integer _
) As Integer
protected:
virtual int GetGlyphHeight(
    Glyph^ glyph,
    int barMinHeight,
    int barMaxHeight
) override
Parameters
glyph (Glyph)
The glyph.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan8BarcodeDraw.GetGlyphHeight(Zen.Barcode.Glyph,System.Int32,System.Int32)]

Remarks
For EAN 13 the only full height glyphs are start/stop/seperator glyphs.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


CodeEan8Checksum Class

CodeEan8Checksum Class
Namespaces ► Zen.Barcode ► CodeEan8Checksum
Barcode Framework Version: v2.0.3.0
CodeEan8Checksum implements a Code EAN-8 checksum generator as a singleton class.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CodeEan8Checksum : FactoryChecksum<CodeEan8GlyphFactory>
Public NotInheritable Class CodeEan8Checksum _
    Inherits FactoryChecksum(Of CodeEan8GlyphFactory)
public ref class CodeEan8Checksum sealed : public FactoryChecksum<CodeEan8GlyphFactory^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory. (Inherited from FactoryChecksum<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetChecksumChar(String) | Gets the checksum char.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the static CodeEan8Checksum object instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class cannot be inherited from.
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum <(Of <( CodeEan8GlyphFactory >)>)
 |  |  | CodeEan8Checksum


GetChecksum Method (text, allowComposite)

GetChecksum Method (text, allowComposite)
Namespaces ► Zen.Barcode ► CodeEan8Checksum ► GetChecksum(String, Boolean)
Barcode Framework Version: v2.0.3.0
Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetChecksum(
    string text,
    bool allowComposite
)
Public Overrides Function GetChecksum ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetChecksum(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
Text to be processed.
allowComposite (Boolean)
if set to true [allow composite].
Return Value
A collection of Glyph objects representing the checksum information.


GetChecksumChar Method (text)

GetChecksumChar Method (text)
Namespaces ► Zen.Barcode ► CodeEan8Checksum ► GetChecksumChar(String)
Barcode Framework Version: v2.0.3.0
Gets the checksum char.
Declaration Syntax
C# Visual Basic Visual C++
public char GetChecksumChar(
    string text
)
Public Function GetChecksumChar ( _
    text As String _
) As Char
public:
wchar_t GetChecksumChar(
    String^ text
)
Parameters
text (String)
The text.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan8Checksum.GetChecksumChar(System.String)]


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► CodeEan8Checksum ► Instance
Barcode Framework Version: v2.0.3.0
Gets the static CodeEan8Checksum object instance.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan8Checksum Instance { get; }
Public Shared ReadOnly Property Instance As CodeEan8Checksum
public:
static property CodeEan8Checksum^ Instance {
    CodeEan8Checksum^ get ();
}


CodeEan8GlyphFactory Class

CodeEan8GlyphFactory Class
Namespaces ► Zen.Barcode ► CodeEan8GlyphFactory
Barcode Framework Version: v2.0.3.0
CodeEan8GlyphFactory concrete implementation of GlyphFactory for providing Code EAN-8 bar-code glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CodeEan8GlyphFactory : GlyphFactory
Public NotInheritable Class CodeEan8GlyphFactory _
    Inherits GlyphFactory
public ref class CodeEan8GlyphFactory sealed : public GlyphFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character. (Inherited from GlyphFactory.)
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string. (Inherited from GlyphFactory.)
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Inherited from GlyphFactory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index. (Inherited from GlyphFactory.)
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character. (Inherited from GlyphFactory.)
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph. (Inherited from GlyphFactory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the global instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | CodeEan8GlyphFactory


GetGlyphs Method (text, allowComposite)

GetGlyphs Method (text, allowComposite)
Namespaces ► Zen.Barcode ► CodeEan8GlyphFactory ► GetGlyphs(String, Boolean)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified string.
Declaration Syntax
C# Visual Basic Visual C++
public override Glyph[] GetGlyphs(
    string text,
    bool allowComposite
)
Public Overrides Function GetGlyphs ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    String^ text,
    bool allowComposite
) override
Parameters
text (String)
The text.
allowComposite (Boolean)
if set to true [allow composite].
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodeEan8GlyphFactory.GetGlyphs(System.String,System.Boolean)]

Remarks
For this method to work as expected the barcode text should not include the first EAN13 digit (this is used to derive parity and is not rendered) but should include the checksum digit.


Instance Property

Instance Property
Namespaces ► Zen.Barcode ► CodeEan8GlyphFactory ► Instance
Barcode Framework Version: v2.0.3.0
Gets the global instance.
Declaration Syntax
C# Visual Basic Visual C++
public static CodeEan8GlyphFactory Instance { get; }
Public Shared ReadOnly Property Instance As CodeEan8GlyphFactory
public:
static property CodeEan8GlyphFactory^ Instance {
    CodeEan8GlyphFactory^ get ();
}
Value
The instance.


CodePdf417BarcodeDraw Class

CodePdf417BarcodeDraw Class
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw
Barcode Framework Version: v2.0.3.0
Custom barcode drawing class for handling PDF417 2D symbology.
Declaration Syntax
C# Visual Basic Visual C++
public class CodePdf417BarcodeDraw : BarcodeDraw
Public Class CodePdf417BarcodeDraw _
    Inherits BarcodeDraw
public ref class CodePdf417BarcodeDraw : public BarcodeDraw
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodePdf417BarcodeDraw()()() | Initialises an instance of BarcodeDrawCodePdf417.
 | AspectRatio | Gets or sets the barcode aspect ratio.
 | BitColumns | Gets the number of X pixels of outBits.
 | CodeColumns | Gets or sets the number of barcode data columns.
 | CodeRows | Gets or sets the number of Y pixels of outBits. It is also the number of rows in the barcode.
 | Codewords | Gets the codeword array. This array is always 928 elements long. It can be writen to if the option PDF417_USE_RAW_CODEWORDS is set.
 | Draw(String, Int32, Int32) | Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics. (Inherited from BarcodeDraw.)
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height. (Inherited from BarcodeDraw.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorLevel | Gets or sets the error level correction used for the barcode.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultMetrics(Int32) | Gets a BarcodeMetrics object containing default settings for the specified maximum bar height. (Overrides BarcodeDraw.GetDefaultMetrics(Int32).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrintMetrics(Size, Size, Int32) | Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution. (Overrides BarcodeDraw.GetPrintMetrics(Size, Size, Int32).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LenCodewords | Gets or sets the length of the codewords.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets or sets the options to generate the barcode.
 | OutBits | Gets the raw image bits of the barcode. The image will have to be scaled in the Y direction by yHeight.
 | PaintCode()()() | Paints the barcode. If no exception was thrown a valid barcode is available.
 | setDefaultParameters()()() | Set the default settings that correspond to PDF417_USE_ASPECT_RATIO and PDF417_AUTO__errorLevel.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | YHeight | Gets or sets the Y pixel height relative to X.
Inheritance Hierarchy
Object
 | BarcodeDraw
 |  | CodePdf417BarcodeDraw


CodePdf417BarcodeDraw Constructor

CodePdf417BarcodeDraw Constructor
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► CodePdf417BarcodeDraw()()()
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeDrawCodePdf417.
Declaration Syntax
C# Visual Basic Visual C++
public CodePdf417BarcodeDraw()
Public Sub New
public:
CodePdf417BarcodeDraw()


AspectRatio Property

AspectRatio Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► AspectRatio
Barcode Framework Version: v2.0.3.0
Gets or sets the barcode aspect ratio.
Declaration Syntax
C# Visual Basic Visual C++
public float AspectRatio { get; set; }
Public Property AspectRatio As Single
public:
property float AspectRatio {
    float get ();
    void set (float value);
}
Value
The barcode aspect ratio.
Remarks
A ratio or 0.5 will make the barcode width twice as large as the height.


BitColumns Property

BitColumns Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► BitColumns
Barcode Framework Version: v2.0.3.0
Gets the number of X pixels of outBits.
Declaration Syntax
C# Visual Basic Visual C++
public int BitColumns { get; }
Public ReadOnly Property BitColumns As Integer
public:
property int BitColumns {
    int get ();
}
Value
The number of X pixels of outBits


CodeColumns Property

CodeColumns Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► CodeColumns
Barcode Framework Version: v2.0.3.0
Gets or sets the number of barcode data columns.
Declaration Syntax
C# Visual Basic Visual C++
public int CodeColumns { get; set; }
Public Property CodeColumns As Integer
public:
property int CodeColumns {
    int get ();
    void set (int value);
}
Value
he number of barcode data columns
Remarks
This number may be changed to keep the barcode valid.


CodeRows Property

CodeRows Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► CodeRows
Barcode Framework Version: v2.0.3.0
Gets or sets the number of Y pixels of outBits. It is also the number of rows in the barcode.
Declaration Syntax
C# Visual Basic Visual C++
public int CodeRows { get; set; }
Public Property CodeRows As Integer
public:
property int CodeRows {
    int get ();
    void set (int value);
}
Value
the number of barcode rows


Codewords Property

Codewords Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Codewords
Barcode Framework Version: v2.0.3.0
Gets the codeword array. This array is always 928 elements long. It can be writen to if the option PDF417_USE_RAW_CODEWORDS is set.
Declaration Syntax
C# Visual Basic Visual C++
public int[] Codewords { get; }
Public ReadOnly Property Codewords As Integer()
public:
property array<int>^ Codewords {
    array<int>^ get ();
}
Value
the codeword array


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


Draw Method (text, barHeight, barWidth)

Draw Method (text, barHeight, barWidth)
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Draw(String, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws a fixed-pitch barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int barHeight,
    int barWidth
)
Public Overrides Function Draw ( _
    text As String, _
    barHeight As Integer, _
    barWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barHeight,
    int barWidth
) override
Parameters
text (String)
The text.
barHeight (Int32)
Height of the bar.
barWidth (Int32)
Width of the bar.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodePdf417BarcodeDraw.Draw(System.String,System.Int32,System.Int32)]


Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Draw(String, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws a variable-pitched barcode for the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public Overrides Function Draw ( _
    text As String, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
text (String)
The text.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodePdf417BarcodeDraw.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32)]


Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)

Draw Method (text, interGlyphSpace, barMinHeight, barMaxHeight, barMinWidth, barMaxWidth)
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Draw(String, Int32, Int32, Int32, Int32, Int32)
Barcode Framework Version: v2.0.3.0
Draws the specified text.
Declaration Syntax
C# Visual Basic Visual C++
public override Image Draw(
    string text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
)
Public Overrides Function Draw ( _
    text As String, _
    interGlyphSpace As Integer, _
    barMinHeight As Integer, _
    barMaxHeight As Integer, _
    barMinWidth As Integer, _
    barMaxWidth As Integer _
) As Image
public:
virtual Image^ Draw(
    String^ text,
    int interGlyphSpace,
    int barMinHeight,
    int barMaxHeight,
    int barMinWidth,
    int barMaxWidth
) override
Parameters
text (String)
The text.
interGlyphSpace (Int32)
Amount of inter-glyph space (in pixels) to apply.
barMinHeight (Int32)
Height of the bar min.
barMaxHeight (Int32)
Height of the bar max.
barMinWidth (Int32)
Width of the bar min.
barMaxWidth (Int32)
Width of the bar max.
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodePdf417BarcodeDraw.Draw(System.String,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)]


ErrorLevel Property

ErrorLevel Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► ErrorLevel
Barcode Framework Version: v2.0.3.0
Gets or sets the error level correction used for the barcode.
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorLevel { get; set; }
Public Property ErrorLevel As Integer
public:
property int ErrorLevel {
    int get ();
    void set (int value);
}
Value
The error level correction used for the barcode
Remarks
It may different from the previously set value.


GetDefaultMetrics Method (maxHeight)

GetDefaultMetrics Method (maxHeight)
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► GetDefaultMetrics(Int32)
Barcode Framework Version: v2.0.3.0
Gets a BarcodeMetrics object containing default settings for the specified maximum bar height.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetDefaultMetrics(
    int maxHeight
)
Public Overrides Function GetDefaultMetrics ( _
    maxHeight As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetDefaultMetrics(
    int maxHeight
) override
Parameters
maxHeight (Int32)
The maximum barcode height.
Return Value
A BarcodeMetrics object.


GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)

GetPrintMetrics Method (desiredBarcodeDimensions, printResolution, barcodeCharLength)
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► GetPrintMetrics(Size, Size, Int32)
Barcode Framework Version: v2.0.3.0
Overridden. Gets a BarcodeMetrics object containing the print metrics needed for printing a barcode of the specified physical size on a device operating at the specified resolution.
Declaration Syntax
C# Visual Basic Visual C++
public override BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
)
Public Overrides Function GetPrintMetrics ( _
    desiredBarcodeDimensions As Size, _
    printResolution As Size, _
    barcodeCharLength As Integer _
) As BarcodeMetrics
public:
virtual BarcodeMetrics GetPrintMetrics(
    Size desiredBarcodeDimensions,
    Size printResolution,
    int barcodeCharLength
) override
Parameters
desiredBarcodeDimensions (Size)
The desired barcode dimensions in hundredth of an inch.
printResolution (Size)
The print resolution in pixels per inch.
barcodeCharLength (Int32)
Length of the barcode in characters.
Return Value
A BarcodeMetrics object.


LenCodewords Property

LenCodewords Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► LenCodewords
Barcode Framework Version: v2.0.3.0
Gets or sets the length of the codewords.
Declaration Syntax
C# Visual Basic Visual C++
public int LenCodewords { get; set; }
Public Property LenCodewords As Integer
public:
property int LenCodewords {
    int get ();
    void set (int value);
}
Value
the length of the codewords.


Options Property

Options Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► Options
Barcode Framework Version: v2.0.3.0
Gets or sets the options to generate the barcode.
Declaration Syntax
C# Visual Basic Visual C++
public PdfRenderFlags Options { get; set; }
Public Property Options As PdfRenderFlags
public:
property PdfRenderFlags Options {
    PdfRenderFlags get ();
    void set (PdfRenderFlags value);
}
Value
The options to generate the barcode taken from the PdfRenderFlags enumeration.


OutBits Property

OutBits Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► OutBits
Barcode Framework Version: v2.0.3.0
Gets the raw image bits of the barcode. The image will have to be scaled in the Y direction by yHeight.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] OutBits { get; }
Public ReadOnly Property OutBits As Byte()
public:
property array<unsigned char>^ OutBits {
    array<unsigned char>^ get ();
}
Value
The raw barcode image bits.


PaintCode Method

PaintCode Method
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► PaintCode()()()
Barcode Framework Version: v2.0.3.0
Paints the barcode. If no exception was thrown a valid barcode is available.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Image PaintCode()
Public Overridable Function PaintCode As Image
public:
virtual Image^ PaintCode()
Return Value

[Missing <returns> documentation for M:Zen.Barcode.CodePdf417BarcodeDraw.PaintCode]


setDefaultParameters Method

setDefaultParameters Method
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► setDefaultParameters()()()
Barcode Framework Version: v2.0.3.0
Set the default settings that correspond to PDF417_USE_ASPECT_RATIO and PDF417_AUTO__errorLevel.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void setDefaultParameters()
Public Overridable Sub setDefaultParameters
public:
virtual void setDefaultParameters()


YHeight Property

YHeight Property
Namespaces ► Zen.Barcode ► CodePdf417BarcodeDraw ► YHeight
Barcode Framework Version: v2.0.3.0
Gets or sets the Y pixel height relative to X.
Declaration Syntax
C# Visual Basic Visual C++
public float YHeight { get; set; }
Public Property YHeight As Single
public:
property float YHeight {
    float get ();
    void set (float value);
}
Value
The Y pixel height relative to X


CompositeGlyph Class

CompositeGlyph Class
Namespaces ► Zen.Barcode ► CompositeGlyph
Barcode Framework Version: v2.0.3.0
Represents a composite glyph.
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeGlyph : Glyph
Public Class CompositeGlyph _
    Inherits Glyph
public ref class CompositeGlyph : public Glyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeGlyph(Char, BarGlyph, BarGlyph) | Initializes a new instance of the CompositeGlyph class.
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | First | Gets the first BarGlyph object.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Second | Gets the second BarGlyph object.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Composite glyphs are used exclusively to represent traps for implementing full ASCII encoding mechanisms used in a variety of barcode symbologies. Both Code 39 and Code 93 use this scheme.
Inheritance Hierarchy
Object
 | Glyph
 |  | CompositeGlyph


CompositeGlyph Constructor (character, first, second)

CompositeGlyph Constructor (character, first, second)
Namespaces ► Zen.Barcode ► CompositeGlyph ► CompositeGlyph(Char, BarGlyph, BarGlyph)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the CompositeGlyph class.
Declaration Syntax
C# Visual Basic Visual C++
public CompositeGlyph(
    char character,
    BarGlyph first,
    BarGlyph second
)
Public Sub New ( _
    character As Char, _
    first As BarGlyph, _
    second As BarGlyph _
)
public:
CompositeGlyph(
    wchar_t character,
    BarGlyph^ first,
    BarGlyph^ second
)
Parameters
character (Char)
The character.
first (BarGlyph)
The first.
second (BarGlyph)
The second.


First Property

First Property
Namespaces ► Zen.Barcode ► CompositeGlyph ► First
Barcode Framework Version: v2.0.3.0
Gets the first BarGlyph object.
Declaration Syntax
C# Visual Basic Visual C++
public BarGlyph First { get; }
Public ReadOnly Property First As BarGlyph
public:
property BarGlyph^ First {
    BarGlyph^ get ();
}
Value
A BarGlyph.


Second Property

Second Property
Namespaces ► Zen.Barcode ► CompositeGlyph ► Second
Barcode Framework Version: v2.0.3.0
Gets the second BarGlyph object.
Declaration Syntax
C# Visual Basic Visual C++
public BarGlyph Second { get; }
Public ReadOnly Property Second As BarGlyph
public:
property BarGlyph^ Second {
    BarGlyph^ get ();
}
Value
A BarGlyph.


FactoryChecksum(T) Class

FactoryChecksum<(Of <(T>)>) Class
Namespaces ► Zen.Barcode ► FactoryChecksum<(Of <(T>)>)
Barcode Framework Version: v2.0.3.0
FactoryChecksum defines the base class for all checksum classes that are attached to an object derived from GlyphFactory for fetching the checksum glyph characters.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class FactoryChecksum<T> : Checksum
where T : GlyphFactory

Public MustInherit Class FactoryChecksum(Of T As GlyphFactory) _
    Inherits Checksum
generic<typename T>
where T : GlyphFactory
public ref class FactoryChecksum abstract : public Checksum
Generic Template Parameters
T
A factory class derived from GlyphFactory.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FactoryChecksum<(Of <(T>)>)(T) | Initialises a new instance of FactoryChecksum class with the specified GlyphFactory derived object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the T type-safe glyph factory.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string. (Inherited from Checksum.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Checksum
 |  | FactoryChecksum<(Of <(T>)>)
 |  |  | Code11Checksum
 |  |  | Code128Checksum
 |  |  | Code25Checksum
 |  |  | Code39Checksum
 |  |  | Code93Checksum
 |  |  | CodeEan13Checksum
 |  |  | CodeEan8Checksum


FactoryChecksum(T) Constructor (factory)

FactoryChecksum<(Of <(T>)>) Constructor (factory)
Namespaces ► Zen.Barcode ► FactoryChecksum<(Of <(T>)>) ► FactoryChecksum<(Of <(T>)>)(T)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of FactoryChecksum class with the specified GlyphFactory derived object.
Declaration Syntax
C# Visual Basic Visual C++
protected FactoryChecksum(
    T factory
)
Protected Sub New ( _
    factory As T _
)
protected:
FactoryChecksum(
    T factory
)
Parameters
factory (T)
Factory to associate with the checksum generator.


Factory Property

Factory Property
Namespaces ► Zen.Barcode ► FactoryChecksum<(Of <(T>)>) ► Factory
Barcode Framework Version: v2.0.3.0
Gets the T type-safe glyph factory.
Declaration Syntax
C# Visual Basic Visual C++
public T Factory { get; }
Public ReadOnly Property Factory As T
public:
property T Factory {
    T get ();
}
Value
The T factory.


Glyph Class

Glyph Class
Namespaces ► Zen.Barcode ► Glyph
Barcode Framework Version: v2.0.3.0
Glyph represents the base class for describing a barcode character.
Declaration Syntax
C# Visual Basic Visual C++
public class Glyph : IGlyph
Public Class Glyph _
    Implements IGlyph
public ref class Glyph : IGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Glyph(Char) | Initialises a new instance of the Glyph class with the specified bit encoding.
 | Character | Gets the Char character associated with this glyph.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

In almost all cases barcode symbologies should not be derived directly from this class but instead from the fixed pitch or variable pitch derived classes which contain functionality to control bar width.

The glyph classes are typically flyweight objects containing immutable state making them suitable for distribution from static class factories - aka symbology factories.

Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  | CompositeGlyph


Glyph Constructor (character)

Glyph Constructor (character)
Namespaces ► Zen.Barcode ► Glyph ► Glyph(Char)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of the Glyph class with the specified bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
public Glyph(
    char character
)
Public Sub New ( _
    character As Char _
)
public:
Glyph(
    wchar_t character
)
Parameters
character (Char)
Character represented by glyph.


Character Property

Character Property
Namespaces ► Zen.Barcode ► Glyph ► Character
Barcode Framework Version: v2.0.3.0
Gets the Char character associated with this glyph.
Declaration Syntax
C# Visual Basic Visual C++
public char Character { get; }
Public ReadOnly Property Character As Char
public:
virtual property wchar_t Character {
    wchar_t get () sealed;
}
Value
The character.


GlyphFactory Class

GlyphFactory Class
Namespaces ► Zen.Barcode ► GlyphFactory
Barcode Framework Version: v2.0.3.0
Abstract class factory for retrieval of barcode glyph objects.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class GlyphFactory
Public MustInherit Class GlyphFactory
public ref class GlyphFactory abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GlyphFactory()()() | Initializes a new instance of the GlyphFactory class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompositeGlyphs()()() | Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology.
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRawCharIndex(Char) | Gets the ordinal position for the specified character.
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.
 | GetRawGlyphIndex(BarGlyph) | Gets the index of this glyph.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The [M:GetGlyphs] and [M:GetCompositeGlyphs] methods must be implemented in derived classes.
Inheritance Hierarchy
Object
 | GlyphFactory
 |  | Code11GlyphFactory
 |  | Code128GlyphFactory
 |  | Code25GlyphFactory
 |  | Code39GlyphFactory
 |  | Code93GlyphFactory
 |  | CodeEan13GlyphFactory
 |  | CodeEan8GlyphFactory


GlyphFactory Constructor

GlyphFactory Constructor
Namespaces ► Zen.Barcode ► GlyphFactory ► GlyphFactory()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the GlyphFactory class.
Declaration Syntax
C# Visual Basic Visual C++
protected GlyphFactory()
Protected Sub New
protected:
GlyphFactory()


GetCompositeGlyphs Method

GetCompositeGlyphs Method
Namespaces ► Zen.Barcode ► GlyphFactory ► GetCompositeGlyphs()()()
Barcode Framework Version: v2.0.3.0
Gets the collection of CompositeGlyph that represent the composite bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract CompositeGlyph[] GetCompositeGlyphs()
Protected MustOverride Function GetCompositeGlyphs As CompositeGlyph()
protected:
virtual array<CompositeGlyph^>^ GetCompositeGlyphs() abstract
Return Value
The full collection of CompositeGlyph objects associated with this symbology.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract BarGlyph[] GetGlyphs()
Protected MustOverride Function GetGlyphs As BarGlyph()
protected:
virtual array<BarGlyph^>^ GetGlyphs() abstract
Return Value
The full collection of BarGlyph objects associated with this symbology.


GetGlyphs Method (character)

GetGlyphs Method (character)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs(Char)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified character.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetGlyphs(
    char character
)
Public Overridable Function GetGlyphs ( _
    character As Char _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    wchar_t character
)
Parameters
character (Char)
The character to be translated.
Return Value
A collection of Glyph objects.
Remarks

This method may return more than one glyph depending on the underlying encoding mechanism being used.

This method will never return composite glyphs.


GetGlyphs Method (character, allowComposite)

GetGlyphs Method (character, allowComposite)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs(Char, Boolean)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified character.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetGlyphs(
    char character,
    bool allowComposite
)
Public Overridable Function GetGlyphs ( _
    character As Char, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    wchar_t character,
    bool allowComposite
)
Parameters
character (Char)
The character to be translated.
allowComposite (Boolean)
if set to true to allow composite glyphs to be returned.
Return Value
A collection of Glyph objects.
Remarks
This method may return more than one glyph depending on the underlying encoding mechanism being used.


GetGlyphs Method (text)

GetGlyphs Method (text)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs(String)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified string.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetGlyphs(
    string text
)
Public Overridable Function GetGlyphs ( _
    text As String _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    String^ text
)
Parameters
text (String)
A String containing text to be translated.
Return Value
A collection of Glyph objects.


GetGlyphs Method (text, allowComposite)

GetGlyphs Method (text, allowComposite)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetGlyphs(String, Boolean)
Barcode Framework Version: v2.0.3.0
Gets the array of Glyph objects that correspond to the specified string.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Glyph[] GetGlyphs(
    string text,
    bool allowComposite
)
Public Overridable Function GetGlyphs ( _
    text As String, _
    allowComposite As Boolean _
) As Glyph()
public:
virtual array<Glyph^>^ GetGlyphs(
    String^ text,
    bool allowComposite
)
Parameters
text (String)
A String containing text to be translated.
allowComposite (Boolean)
if set to true to allow composite glyphs to be returned.
Return Value
A collection of Glyph objects.


GetRawCharIndex Method (character)

GetRawCharIndex Method (character)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetRawCharIndex(Char)
Barcode Framework Version: v2.0.3.0
Gets the ordinal position for the specified character.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetRawCharIndex(
    char character
)
Public Overridable Function GetRawCharIndex ( _
    character As Char _
) As Integer
public:
virtual int GetRawCharIndex(
    wchar_t character
)
Parameters
character (Char)
The character to be located.
Return Value
An Int32 representing the character ordinal index.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


GetRawGlyph Method (character)

GetRawGlyph Method (character)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetRawGlyph(Char)
Barcode Framework Version: v2.0.3.0
Gets the BarGlyph that corresponds to the specified character.
Declaration Syntax
C# Visual Basic Visual C++
public virtual BarGlyph GetRawGlyph(
    char character
)
Public Overridable Function GetRawGlyph ( _
    character As Char _
) As BarGlyph
public:
virtual BarGlyph^ GetRawGlyph(
    wchar_t character
)
Parameters
character (Char)
The character to be located.
Return Value
A BarGlyph glyph object.


GetRawGlyph Method (index)

GetRawGlyph Method (index)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetRawGlyph(Int32)
Barcode Framework Version: v2.0.3.0
Gets the BarGlyph at the specified ordinal index.
Declaration Syntax
C# Visual Basic Visual C++
public virtual BarGlyph GetRawGlyph(
    int index
)
Public Overridable Function GetRawGlyph ( _
    index As Integer _
) As BarGlyph
public:
virtual BarGlyph^ GetRawGlyph(
    int index
)
Parameters
index (Int32)
The glyph ordinal index.
Return Value
A BarGlyph glyph object.


GetRawGlyphIndex Method (glyph)

GetRawGlyphIndex Method (glyph)
Namespaces ► Zen.Barcode ► GlyphFactory ► GetRawGlyphIndex(BarGlyph)
Barcode Framework Version: v2.0.3.0
Gets the index of this glyph.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetRawGlyphIndex(
    BarGlyph glyph
)
Public Overridable Function GetRawGlyphIndex ( _
    glyph As BarGlyph _
) As Integer
public:
virtual int GetRawGlyphIndex(
    BarGlyph^ glyph
)
Parameters
glyph (BarGlyph)
The BarGlyph to be located.
Return Value
The ordinal index of the glyph or -1 if not found.


IBarGlyph Interface

IBarGlyph Interface
Namespaces ► Zen.Barcode ► IBarGlyph
Barcode Framework Version: v2.0.3.0
IBarGlyph extends IGlyph by specifying a bit encoding for a given character. The bits indicate where bars are drawn.
Declaration Syntax
C# Visual Basic Visual C++
public interface IBarGlyph : IGlyph
Public Interface IBarGlyph _
    Implements IGlyph
public interface class IBarGlyph : IGlyph
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BitEncoding | Gets the bit encoding.
 | Character | Gets the character. (Inherited from IGlyph.)


BitEncoding Property

BitEncoding Property
Namespaces ► Zen.Barcode ► IBarGlyph ► BitEncoding
Barcode Framework Version: v2.0.3.0
Gets the bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
short BitEncoding { get; }
ReadOnly Property BitEncoding As Short
property short BitEncoding {
    short get ();
}
Value
The bit encoding.


IBinaryPitchGlyph Interface

IBinaryPitchGlyph Interface
Namespaces ► Zen.Barcode ► IBinaryPitchGlyph
Barcode Framework Version: v2.0.3.0
IBinaryPitchGlyph defines the contract with binary pitched glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public interface IBinaryPitchGlyph : IBarGlyph,
    IGlyph
Public Interface IBinaryPitchGlyph _
    Implements IBarGlyph, IGlyph
public interface class IBinaryPitchGlyph : IBarGlyph,
    IGlyph
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BitEncoding | Gets the bit encoding. (Inherited from IBarGlyph.)
 | Character | Gets the character. (Inherited from IGlyph.)
 | WidthEncoding | Gets the width encoding.


WidthEncoding Property

WidthEncoding Property
Namespaces ► Zen.Barcode ► IBinaryPitchGlyph ► WidthEncoding
Barcode Framework Version: v2.0.3.0
Gets the width encoding.
Declaration Syntax
C# Visual Basic Visual C++
short WidthEncoding { get; }
ReadOnly Property WidthEncoding As Short
property short WidthEncoding {
    short get ();
}
Value
The width encoding.


IGlyph Interface

IGlyph Interface
Namespaces ► Zen.Barcode ► IGlyph
Barcode Framework Version: v2.0.3.0
IGlyph defines barcode for a given character.
Declaration Syntax
C# Visual Basic Visual C++
public interface IGlyph
Public Interface IGlyph
public interface class IGlyph
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Character | Gets the character.


Character Property

Character Property
Namespaces ► Zen.Barcode ► IGlyph ► Character
Barcode Framework Version: v2.0.3.0
Gets the character.
Declaration Syntax
C# Visual Basic Visual C++
char Character { get; }
ReadOnly Property Character As Char
property wchar_t Character {
    wchar_t get ();
}
Value
The character.


IVaryLengthGlyph Interface

IVaryLengthGlyph Interface
Namespaces ► Zen.Barcode ► IVaryLengthGlyph
Barcode Framework Version: v2.0.3.0
IVaryLengthGlyph identifies a glyph object as supporting a custom bit encoding width
Declaration Syntax
C# Visual Basic Visual C++
public interface IVaryLengthGlyph : IBarGlyph,
    IGlyph
Public Interface IVaryLengthGlyph _
    Implements IBarGlyph, IGlyph
public interface class IVaryLengthGlyph : IBarGlyph,
    IGlyph
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BitEncoding | Gets the bit encoding. (Inherited from IBarGlyph.)
 | BitEncodingWidth | Gets the number of bits used for the bit encoding.
 | Character | Gets the character. (Inherited from IGlyph.)


BitEncodingWidth Property

BitEncodingWidth Property
Namespaces ► Zen.Barcode ► IVaryLengthGlyph ► BitEncodingWidth
Barcode Framework Version: v2.0.3.0
Gets the number of bits used for the bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
short BitEncodingWidth { get; }
ReadOnly Property BitEncodingWidth As Short
property short BitEncodingWidth {
    short get ();
}
Value
The width encoding.


MultisetGlyph Class

MultisetGlyph Class
Namespaces ► Zen.Barcode ► MultisetGlyph
Barcode Framework Version: v2.0.3.0
MultisetGlyph serves as a base class for barcode symbologies where a given encoding is reused by multiple characters.
Declaration Syntax
C# Visual Basic Visual C++
public class MultisetGlyph : BarGlyph
Public Class MultisetGlyph _
    Inherits BarGlyph
public ref class MultisetGlyph : public BarGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultisetGlyph(array<Char>[]()[], Int16) | Initialises a new instance of MultisetGlyph class.
 | BitEncoding | Gets the bit encoding for this glyph. (Inherited from BarGlyph.)
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCharacterBySet(Int32) | Gets the character representation for the specified character set.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Sets | Gets an Int32 that represents the number of character sets encoded in this glyph.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | MultisetGlyph
 |  |  |  | Code128Glyph


MultisetGlyph Constructor (characters, bitEncoding)

MultisetGlyph Constructor (characters, bitEncoding)
Namespaces ► Zen.Barcode ► MultisetGlyph ► MultisetGlyph(array<Char>[]()[], Int16)
Barcode Framework Version: v2.0.3.0
Initialises a new instance of MultisetGlyph class.
Declaration Syntax
C# Visual Basic Visual C++
public MultisetGlyph(
    char[] characters,
    short bitEncoding
)
Public Sub New ( _
    characters As Char(), _
    bitEncoding As Short _
)
public:
MultisetGlyph(
    array<wchar_t>^ characters,
    short bitEncoding
)
Parameters
characters (array< Char >[]()[])

[Missing <param name="characters"/> documentation for "M:Zen.Barcode.MultisetGlyph.#ctor(System.Char[],System.Int16)"]

bitEncoding (Int16)

[Missing <param name="bitEncoding"/> documentation for "M:Zen.Barcode.MultisetGlyph.#ctor(System.Char[],System.Int16)"]


GetCharacterBySet Method (set)

GetCharacterBySet Method (set)
Namespaces ► Zen.Barcode ► MultisetGlyph ► GetCharacterBySet(Int32)
Barcode Framework Version: v2.0.3.0
Gets the character representation for the specified character set.
Declaration Syntax
C# Visual Basic Visual C++
public char GetCharacterBySet(
    int set
)
Public Function GetCharacterBySet ( _
    set As Integer _
) As Char
public:
wchar_t GetCharacterBySet(
    int set
)
Parameters
set (Int32)

[Missing <param name="set"/> documentation for "M:Zen.Barcode.MultisetGlyph.GetCharacterBySet(System.Int32)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.MultisetGlyph.GetCharacterBySet(System.Int32)]


Sets Property

Sets Property
Namespaces ► Zen.Barcode ► MultisetGlyph ► Sets
Barcode Framework Version: v2.0.3.0
Gets an Int32 that represents the number of character sets encoded in this glyph.
Declaration Syntax
C# Visual Basic Visual C++
public int Sets { get; }
Public ReadOnly Property Sets As Integer
public:
property int Sets {
    int get ();
}


PdfRenderFlags Enumeration

PdfRenderFlags Enumeration
Namespaces ► Zen.Barcode ► PdfRenderFlags
Barcode Framework Version: v2.0.3.0

[Missing <summary> documentation for T:Zen.Barcode.PdfRenderFlags]

Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PdfRenderFlags
<FlagsAttribute> _
Public Enumeration PdfRenderFlags
[FlagsAttribute]
public enum class PdfRenderFlags
Members
Member | Description
UseAspectRatio |
FixedRectangle |
FixedColumns |
FixedRows |
AutoErrorLevel |
UseErrorLevel |
UseRawCodeWords |
InvertBitmap |


VaryLengthGlyph Class

VaryLengthGlyph Class
Namespaces ► Zen.Barcode ► VaryLengthGlyph
Barcode Framework Version: v2.0.3.0
VaryLengthGlyph serves as a base class for variable length fixed-pitch bar-code glyphs.
Declaration Syntax
C# Visual Basic Visual C++
public class VaryLengthGlyph : BarGlyph,
    IVaryLengthGlyph, IBarGlyph, IGlyph
Public Class VaryLengthGlyph _
    Inherits BarGlyph _
    Implements IVaryLengthGlyph, IBarGlyph, IGlyph
public ref class VaryLengthGlyph : public BarGlyph,
    IVaryLengthGlyph, IBarGlyph, IGlyph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VaryLengthGlyph(Char, Int16, Int16) | Initializes a new instance of the VaryLengthGlyph class.
 | BitEncoding | Gets the bit encoding for this glyph. (Inherited from BarGlyph.)
 | BitEncodingWidth | Gets the number of bits used for the bit encoding.
 | Character | Gets the Char character associated with this glyph. (Inherited from Glyph.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Glyph
 |  | BarGlyph
 |  |  | VaryLengthGlyph


VaryLengthGlyph Constructor (character, bitEncoding, bitEncodingWidth)

VaryLengthGlyph Constructor (character, bitEncoding, bitEncodingWidth)
Namespaces ► Zen.Barcode ► VaryLengthGlyph ► VaryLengthGlyph(Char, Int16, Int16)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the VaryLengthGlyph class.
Declaration Syntax
C# Visual Basic Visual C++
public VaryLengthGlyph(
    char character,
    short bitEncoding,
    short bitEncodingWidth
)
Public Sub New ( _
    character As Char, _
    bitEncoding As Short, _
    bitEncodingWidth As Short _
)
public:
VaryLengthGlyph(
    wchar_t character,
    short bitEncoding,
    short bitEncodingWidth
)
Parameters
character (Char)
The character.
bitEncoding (Int16)
The bit encoding.
bitEncodingWidth (Int16)
Width of the bit encoding.


BitEncodingWidth Property

BitEncodingWidth Property
Namespaces ► Zen.Barcode ► VaryLengthGlyph ► BitEncodingWidth
Barcode Framework Version: v2.0.3.0
Gets the number of bits used for the bit encoding.
Declaration Syntax
C# Visual Basic Visual C++
public short BitEncodingWidth { get; }
Public ReadOnly Property BitEncodingWidth As Short
public:
virtual property short BitEncodingWidth {
    short get () sealed;
}
Value
The width encoding.


Zen.Barcode.Web Namespace

Zen.Barcode.Web Namespace
Namespaces ► Zen.Barcode.Web
Barcode Framework Version: v2.0.3.0
Contains all ASP.NET barcode support objects.
Declaration Syntax
C# Visual Basic Visual C++
namespace Zen.Barcode.Web
Namespace Zen.Barcode.Web
namespace Zen.Barcode.Web
Types
All Types Classes
Icon | Type | Description
 | BarcodeImageHandler | BarcodeImageHandler is a custom ASP.NET HTTP Handler for streaming bar-code images to a web-client.
 | BarcodeImageUri | This class is used to generate URIs which when requested by the client will result in a barcode image being streamed from the database as a standard JPEG file. For all of this to work the following line must be added to web.config in the httpHandler section <add verb="GET" path="*.Barcode" type="Zen.Barcode.Web.BarcodeImageHandler, Zen.Barcode.Web, Culture=Neutral, Version=2.0.2.0, PublicKeyToken=b5ae55aa76d2d9de" /> The .Barcode file extension will need to be associated with ASP.NET from within IIS and the "Check if the file exists" checkbox must be cleared.
 | BarcodeImageUriBuilder | Provides a custom constructor for barcode uniform resource identifiers (URIs) and modifies URIs for the BarcodeImageUri class.
 | BarcodeLabel | BarcodeLabel renders bar-codes in a variety of formats.
 | BarcodeXml | BarcodeXml web-control replaces Xml by automatically registering our custom extension object that is used to translate design IDs and barcode text into image URIs suitable for use in the transformed HTML - uber cool!


BarcodeImageHandler Class

BarcodeImageHandler Class
Namespaces ► Zen.Barcode.Web ► BarcodeImageHandler
Barcode Framework Version: v2.0.3.0
BarcodeImageHandler is a custom ASP.NET HTTP Handler for streaming bar-code images to a web-client.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BarcodeImageHandler : IHttpAsyncHandler,
    IHttpHandler
Public NotInheritable Class BarcodeImageHandler _
    Implements IHttpAsyncHandler, IHttpHandler
public ref class BarcodeImageHandler sealed : IHttpAsyncHandler,
    IHttpHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BarcodeImageHandler()()() | Initializes a new instance of the BarcodeImageHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

The bar-code symbology and size metrics are encoded into the image filename by BarcodeImageUrlBuilder.

Currently the image format is fixed as JPEG.

For ultimate performance this is an asynchronous HTTP handler with work performed on a thread-pooled thread.

Inheritance Hierarchy
Object
BarcodeImageHandler

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageHandler Constructor

BarcodeImageHandler Constructor
Namespaces ► Zen.Barcode.Web ► BarcodeImageHandler ► BarcodeImageHandler()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the BarcodeImageHandler class
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeImageHandler()
Public Sub New
public:
BarcodeImageHandler()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUri Class

BarcodeImageUri Class
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri
Barcode Framework Version: v2.0.3.0

This class is used to generate URIs which when requested by the client will result in a barcode image being streamed from the database as a standard JPEG file.

For all of this to work the following line must be added to web.config in the httpHandler section <add verb="GET" path="*.Barcode" type="Zen.Barcode.Web.BarcodeImageHandler, Zen.Barcode.Web, Culture=Neutral, Version=2.0.2.0, PublicKeyToken=b5ae55aa76d2d9de" /> The .Barcode file extension will need to be associated with ASP.NET from within IIS and the "Check if the file exists" checkbox must be cleared.

Declaration Syntax
C# Visual Basic Visual C++
public class BarcodeImageUri
Public Class BarcodeImageUri
public ref class BarcodeImageUri
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeImageUri(Uri) | Initializes a new instance of the BarcodeImageUri class.
 | BarcodeImageUri(String) | Initializes a new instance of the BarcodeImageUri class.
 | BarMaxHeight | Gets the height of the bar max.
 | BarMaxWidth | Gets the width of the bar max.
 | BarMinHeight | Gets the height of the bar min.
 | BarMinWidth | Gets the width of the bar min.
 | EncodingScheme | Gets the encoding scheme.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Gets the name of the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BarcodeImageUri

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUri Constructor

BarcodeImageUri Constructor
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarcodeImageUri()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | BarcodeImageUri(Uri) | Initializes a new instance of the BarcodeImageUri class.
 | BarcodeImageUri(String) | Initializes a new instance of the BarcodeImageUri class.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUri Constructor (fileName)

BarcodeImageUri Constructor (fileName)
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarcodeImageUri(String)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the BarcodeImageUri class.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeImageUri(
    string fileName
)
Public Sub New ( _
    fileName As String _
)
public:
BarcodeImageUri(
    String^ fileName
)
Parameters
fileName (String)
Name of the file.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUri Constructor (uri)

BarcodeImageUri Constructor (uri)
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarcodeImageUri(Uri)
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the BarcodeImageUri class.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeImageUri(
    Uri uri
)
Public Sub New ( _
    uri As Uri _
)
public:
BarcodeImageUri(
    Uri^ uri
)
Parameters
uri (Uri)
The URI.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxHeight Property

BarMaxHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarMaxHeight
Barcode Framework Version: v2.0.3.0
Gets the height of the bar max.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxHeight { get; }
Public ReadOnly Property BarMaxHeight As Integer
public:
property int BarMaxHeight {
    int get ();
}
Value
The height of the bar max.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxWidth Property

BarMaxWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarMaxWidth
Barcode Framework Version: v2.0.3.0
Gets the width of the bar max.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxWidth { get; }
Public ReadOnly Property BarMaxWidth As Integer
public:
property int BarMaxWidth {
    int get ();
}
Value
The width of the bar max.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinHeight Property

BarMinHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarMinHeight
Barcode Framework Version: v2.0.3.0
Gets the height of the bar min.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinHeight { get; }
Public ReadOnly Property BarMinHeight As Integer
public:
property int BarMinHeight {
    int get ();
}
Value
The height of the bar min.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinWidth Property

BarMinWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► BarMinWidth
Barcode Framework Version: v2.0.3.0
Gets the width of the bar min.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinWidth { get; }
Public ReadOnly Property BarMinWidth As Integer
public:
property int BarMinWidth {
    int get ();
}
Value
The width of the bar min.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


EncodingScheme Property

EncodingScheme Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► EncodingScheme
Barcode Framework Version: v2.0.3.0
Gets the encoding scheme.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeSymbology EncodingScheme { get; }
Public ReadOnly Property EncodingScheme As BarcodeSymbology
public:
property BarcodeSymbology EncodingScheme {
    BarcodeSymbology get ();
}
Value
The encoding scheme.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


FileName Property

FileName Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► FileName
Barcode Framework Version: v2.0.3.0
Gets the name of the file.
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
public:
property String^ FileName {
    String^ get ();
}
Value
The name of the file.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Text Property

Text Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUri ► Text
Barcode Framework Version: v2.0.3.0
Gets the text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}
Value
The text.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUriBuilder Class

BarcodeImageUriBuilder Class
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder
Barcode Framework Version: v2.0.3.0
Provides a custom constructor for barcode uniform resource identifiers (URIs) and modifies URIs for the BarcodeImageUri class.
Declaration Syntax
C# Visual Basic Visual C++
public class BarcodeImageUriBuilder
Public Class BarcodeImageUriBuilder
public ref class BarcodeImageUriBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeImageUriBuilder()()() | Initializes a new instance of the BarcodeImageUriBuilder class.
 | BarMaxHeight | Gets/sets an Int32 that determines the height of the rendered bar-code.
 | BarMaxWidth | Gets or sets the width of the bar max.
 | BarMinHeight | Gets/sets an Int32 that determines the height of the rendered bar-code.
 | BarMinWidth | Gets or sets the width of the bar min.
 | EncodingScheme | Gets/sets the barcode encoding scheme
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | The barcode string to be encoded
 | ToString()()() | Overridden. Gets a textual representation of the build URI. (Overrides Object.ToString()()().)
 | Uri | Gets the built BarcodeImageUri that represents the current state of the builder.
Remarks

The BarcodeImageUriBuilder class provides a convenient way to modify the contents of a BarcodeImageUri instance without creating a new BarcodeImageUri instance for each modification.

The BarcodeImageUriBuilder properties provide read/write access to the read-only BarcodeImageUri properties so that they can be modified.

Inheritance Hierarchy
Object
BarcodeImageUriBuilder

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeImageUriBuilder Constructor

BarcodeImageUriBuilder Constructor
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► BarcodeImageUriBuilder()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the BarcodeImageUriBuilder class.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeImageUriBuilder()
Public Sub New
public:
BarcodeImageUriBuilder()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxHeight Property

BarMaxHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► BarMaxHeight
Barcode Framework Version: v2.0.3.0
Gets/sets an Int32 that determines the height of the rendered bar-code.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxHeight { get; set; }
Public Property BarMaxHeight As Integer
public:
property int BarMaxHeight {
    int get ();
    void set (int value);
}
Value
The height of the bar max.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxWidth Property

BarMaxWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► BarMaxWidth
Barcode Framework Version: v2.0.3.0
Gets or sets the width of the bar max.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxWidth { get; set; }
Public Property BarMaxWidth As Integer
public:
property int BarMaxWidth {
    int get ();
    void set (int value);
}
Value
The width of the bar max.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinHeight Property

BarMinHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► BarMinHeight
Barcode Framework Version: v2.0.3.0
Gets/sets an Int32 that determines the height of the rendered bar-code.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinHeight { get; set; }
Public Property BarMinHeight As Integer
public:
property int BarMinHeight {
    int get ();
    void set (int value);
}
Value
The height of the bar min.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinWidth Property

BarMinWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► BarMinWidth
Barcode Framework Version: v2.0.3.0
Gets or sets the width of the bar min.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinWidth { get; set; }
Public Property BarMinWidth As Integer
public:
property int BarMinWidth {
    int get ();
    void set (int value);
}
Value
The width of the bar min.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


EncodingScheme Property

EncodingScheme Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► EncodingScheme
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode encoding scheme
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeSymbology EncodingScheme { get; set; }
Public Property EncodingScheme As BarcodeSymbology
public:
property BarcodeSymbology EncodingScheme {
    BarcodeSymbology get ();
    void set (BarcodeSymbology value);
}
Value
A value from the BarcodeSymbology enumeration.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Text Property

Text Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► Text
Barcode Framework Version: v2.0.3.0
The barcode string to be encoded
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
Value
The text.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


ToString Method

ToString Method
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► ToString()()()
Barcode Framework Version: v2.0.3.0
Overridden. Gets a textual representation of the build URI.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.BarcodeImageUriBuilder.ToString]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Uri Property

Uri Property
Namespaces ► Zen.Barcode.Web ► BarcodeImageUriBuilder ► Uri
Barcode Framework Version: v2.0.3.0
Gets the built BarcodeImageUri that represents the current state of the builder.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeImageUri Uri { get; }
Public ReadOnly Property Uri As BarcodeImageUri
public:
property BarcodeImageUri^ Uri {
    BarcodeImageUri^ get ();
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeLabel Class

BarcodeLabel Class
Namespaces ► Zen.Barcode.Web ► BarcodeLabel
Barcode Framework Version: v2.0.3.0
BarcodeLabel renders bar-codes in a variety of formats.
Declaration Syntax
C# Visual Basic Visual C++
public class BarcodeLabel : CompositeControl
Public Class BarcodeLabel _
    Inherits CompositeControl
public ref class BarcodeLabel : public CompositeControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeLabel()()() | Initialises an instance of BarcodeLabel.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BarcodeEncoding | Gets/sets the barcode encoding scheme.
 | BarcodeRowStyle | Gets the Style object associated with the content row.
 | BarMaxHeight | Gets/sets the barcode maximum height in pixels.
 | BarMaxWidth | Gets/sets the barcode maximum bar width in pixels.
 | BarMinHeight | Gets/sets the barcode minimum height in pixels.
 | BarMinWidth | Gets/sets the barcode minimum bar width in pixels.
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls in a CompositeControl. (Inherited from CompositeControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Overridden. Creates the child nested controls. (Overrides Control.CreateChildControls()()().)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Overridden. Creates the control style object. (Overrides WebControl.CreateControlStyle()()().)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the CompositeControl and all its child controls. (Inherited from CompositeControl.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LabelHorizontalAlign | Gets/sets the horizontal alignment of the label.
 | LabelRowStyle | Gets the Style object associated with the content row.
 | LabelVerticalAlign | Gets/sets the vertical alignment of the label.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Overridden. Loads the view-state information previously saved by invoking SaveViewState method. (Overrides WebControl.LoadViewState(Object).)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PrepareControlHierarchy()()() | Prepares our composite controls for rendering by setting last-minute (ie: non-viewstate tracked) properties.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RecreateChildControls()()() | Recreates the child controls in a control derived from CompositeControl. (Inherited from CompositeControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Overridden. Renders this control to the specified HtmlTextWriter object. (Overrides CompositeControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Overridden. Saves any state that was modified after the TrackViewState method was invoked. (Overrides WebControl.SaveViewState()()().)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | ShowLabel | Gets/sets a boolean value controlling whether the label is shown together with the barcode.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets/sets the text that will be rendered as a barcode.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Instructs the control to start tracking changes to view-state. (Overrides WebControl.TrackViewState()()().)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CompositeControl
 |  |  |  | BarcodeLabel

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeLabel Constructor

BarcodeLabel Constructor
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarcodeLabel()()()
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeLabel.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeLabel()
Public Sub New
public:
BarcodeLabel()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeEncoding Property

BarcodeEncoding Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarcodeEncoding
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode encoding scheme.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeSymbology BarcodeEncoding { get; set; }
Public Property BarcodeEncoding As BarcodeSymbology
public:
property BarcodeSymbology BarcodeEncoding {
    BarcodeSymbology get ();
    void set (BarcodeSymbology value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeRowStyle Property

BarcodeRowStyle Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarcodeRowStyle
Barcode Framework Version: v2.0.3.0
Gets the Style object associated with the content row.
Declaration Syntax
C# Visual Basic Visual C++
public TableItemStyle BarcodeRowStyle { get; }
Public ReadOnly Property BarcodeRowStyle As TableItemStyle
public:
property TableItemStyle^ BarcodeRowStyle {
    TableItemStyle^ get ();
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxHeight Property

BarMaxHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarMaxHeight
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode maximum height in pixels.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxHeight { get; set; }
Public Property BarMaxHeight As Integer
public:
property int BarMaxHeight {
    int get ();
    void set (int value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMaxWidth Property

BarMaxWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarMaxWidth
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode maximum bar width in pixels.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMaxWidth { get; set; }
Public Property BarMaxWidth As Integer
public:
property int BarMaxWidth {
    int get ();
    void set (int value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinHeight Property

BarMinHeight Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarMinHeight
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode minimum height in pixels.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinHeight { get; set; }
Public Property BarMinHeight As Integer
public:
property int BarMinHeight {
    int get ();
    void set (int value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarMinWidth Property

BarMinWidth Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► BarMinWidth
Barcode Framework Version: v2.0.3.0
Gets/sets the barcode minimum bar width in pixels.
Declaration Syntax
C# Visual Basic Visual C++
public int BarMinWidth { get; set; }
Public Property BarMinWidth As Integer
public:
property int BarMinWidth {
    int get ();
    void set (int value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


CreateChildControls Method

CreateChildControls Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► CreateChildControls()()()
Barcode Framework Version: v2.0.3.0
Overridden. Creates the child nested controls.
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls
protected:
virtual void CreateChildControls() override

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


CreateControlStyle Method

CreateControlStyle Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► CreateControlStyle()()()
Barcode Framework Version: v2.0.3.0
Overridden. Creates the control style object.
Declaration Syntax
C# Visual Basic Visual C++
protected override Style CreateControlStyle()
Protected Overrides Function CreateControlStyle As Style
protected:
virtual Style^ CreateControlStyle() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.BarcodeLabel.CreateControlStyle]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


LabelHorizontalAlign Property

LabelHorizontalAlign Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► LabelHorizontalAlign
Barcode Framework Version: v2.0.3.0
Gets/sets the horizontal alignment of the label.
Declaration Syntax
C# Visual Basic Visual C++
public HorizontalAlign LabelHorizontalAlign { get; set; }
Public Property LabelHorizontalAlign As HorizontalAlign
public:
property HorizontalAlign LabelHorizontalAlign {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


LabelRowStyle Property

LabelRowStyle Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► LabelRowStyle
Barcode Framework Version: v2.0.3.0
Gets the Style object associated with the content row.
Declaration Syntax
C# Visual Basic Visual C++
public TableItemStyle LabelRowStyle { get; }
Public ReadOnly Property LabelRowStyle As TableItemStyle
public:
property TableItemStyle^ LabelRowStyle {
    TableItemStyle^ get ();
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


LabelVerticalAlign Property

LabelVerticalAlign Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► LabelVerticalAlign
Barcode Framework Version: v2.0.3.0
Gets/sets the vertical alignment of the label.
Declaration Syntax
C# Visual Basic Visual C++
public VerticalAlign LabelVerticalAlign { get; set; }
Public Property LabelVerticalAlign As VerticalAlign
public:
property VerticalAlign LabelVerticalAlign {
    VerticalAlign get ();
    void set (VerticalAlign value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


LoadViewState Method (savedState)

LoadViewState Method (savedState)
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► LoadViewState(Object)
Barcode Framework Version: v2.0.3.0
Overridden. Loads the view-state information previously saved by invoking SaveViewState method.
Declaration Syntax
C# Visual Basic Visual C++
protected override void LoadViewState(
    Object savedState
)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)
protected:
virtual void LoadViewState(
    Object^ savedState
) override
Parameters
savedState (Object)

[Missing <param name="savedState"/> documentation for "M:Zen.Barcode.Web.BarcodeLabel.LoadViewState(System.Object)"]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


PrepareControlHierarchy Method

PrepareControlHierarchy Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► PrepareControlHierarchy()()()
Barcode Framework Version: v2.0.3.0
Prepares our composite controls for rendering by setting last-minute (ie: non-viewstate tracked) properties.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void PrepareControlHierarchy()
Protected Overridable Sub PrepareControlHierarchy
protected:
virtual void PrepareControlHierarchy()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Render Method (writer)

Render Method (writer)
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► Render(HtmlTextWriter)
Barcode Framework Version: v2.0.3.0
Overridden. Renders this control to the specified HtmlTextWriter object.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Render(
    HtmlTextWriter writer
)
Protected Overrides Sub Render ( _
    writer As HtmlTextWriter _
)
protected:
virtual void Render(
    HtmlTextWriter^ writer
) override
Parameters
writer (HtmlTextWriter)

[Missing <param name="writer"/> documentation for "M:Zen.Barcode.Web.BarcodeLabel.Render(System.Web.UI.HtmlTextWriter)"]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


SaveViewState Method

SaveViewState Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► SaveViewState()()()
Barcode Framework Version: v2.0.3.0
Overridden. Saves any state that was modified after the TrackViewState method was invoked.
Declaration Syntax
C# Visual Basic Visual C++
protected override Object SaveViewState()
Protected Overrides Function SaveViewState As Object
protected:
virtual Object^ SaveViewState() override
Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.BarcodeLabel.SaveViewState]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


ShowLabel Property

ShowLabel Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► ShowLabel
Barcode Framework Version: v2.0.3.0
Gets/sets a boolean value controlling whether the label is shown together with the barcode.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowLabel { get; set; }
Public Property ShowLabel As Boolean
public:
property bool ShowLabel {
    bool get ();
    void set (bool value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Text Property

Text Property
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► Text
Barcode Framework Version: v2.0.3.0
Gets/sets the text that will be rendered as a barcode.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


TrackViewState Method

TrackViewState Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► TrackViewState()()()
Barcode Framework Version: v2.0.3.0
Instructs the control to start tracking changes to view-state.
Declaration Syntax
C# Visual Basic Visual C++
protected override void TrackViewState()
Protected Overrides Sub TrackViewState
protected:
virtual void TrackViewState() override

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeXml Class

BarcodeXml Class
Namespaces ► Zen.Barcode.Web ► BarcodeXml
Barcode Framework Version: v2.0.3.0
BarcodeXml web-control replaces Xml by automatically registering our custom extension object that is used to translate design IDs and barcode text into image URIs suitable for use in the transformed HTML - uber cool!
Declaration Syntax
C# Visual Basic Visual C++
public class BarcodeXml : Control
Public Class BarcodeXml _
    Inherits Control
public ref class BarcodeXml : public Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeXml()()() | Initialises an instance of BarcodeXml.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Overrides Control.AddParsedSubObject(Object).)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Overrides Control.ClientID.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Overrides Control.Controls.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new EmptyControlCollection object. (Overrides Control.CreateControlCollection()()().)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DocumentContent | Gets/sets a string that contains the XML document to display in the BarcodeXml control.
 | DocumentSource | Gets or sets the path to an XML document to display in the BarcodeXml control.
 | EnableTheming | Overrides the EnableTheming property. This property is not supported by the BarcodeXml class. (Overrides Control.EnableTheming.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for the specified server control. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Overrides the Focus()()() method. This method is not supported by the BarcodeXml class. (Overrides Control.Focus()()().)
 | GetDesignModeState()()() | Gets design-time data for a control. (Overrides Control.GetDesignModeState()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines whether the server control contains any child controls. (Overrides Control.HasControls()()().)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterExtensionObject(String, Object) | Registers the specified extension object under the given namespace allowing methods on the object to be called by XSLT style-sheets.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the results to the output stream. (Overrides Control.Render(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Overrides the SkinID property. This property is not supported by the BarcodeXml class. (Overrides Control.SkinID.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | Transform | Gets or sets the XslTransform object that formats the XML document before it is written to the output stream.
 | TransformArgumentList | Gets or sets a XsltArgumentList that contains a list of optional arguments passed to the style sheet and used during the Extensible Stylesheet Language Transformation (XSLT).
 | TransformSource | Gets or sets the path to an Extensible Stylesheet Language Transformation (XSLT) style sheet that formats the XML document before it is written to the output stream.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | XPathNavigator | Gets or sets a cursor model for navigating and editing the XML data associated with the BarcodeXml control.
Inheritance Hierarchy
Object
 | Control
 |  | BarcodeXml

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


BarcodeXml Constructor

BarcodeXml Constructor
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► BarcodeXml()()()
Barcode Framework Version: v2.0.3.0
Initialises an instance of BarcodeXml.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeXml()
Public Sub New
public:
BarcodeXml()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


AddParsedSubObject Method (obj)

AddParsedSubObject Method (obj)
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► AddParsedSubObject(Object)
Barcode Framework Version: v2.0.3.0
Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
Declaration Syntax
C# Visual Basic Visual C++
protected override void AddParsedSubObject(
    Object obj
)
Protected Overrides Sub AddParsedSubObject ( _
    obj As Object _
)
protected:
virtual void AddParsedSubObject(
    Object^ obj
) override
Parameters
obj (Object)
An Object that represents the LiteralControl to add.
Exceptions
Exception | Condition
HttpException | obj is not of type LiteralControl.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


ClientID Property

ClientID Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► ClientID
Barcode Framework Version: v2.0.3.0
Gets the server control identifier generated by ASP.NET.
Declaration Syntax
C# Visual Basic Visual C++
public override string ClientID { get; }
Public Overrides ReadOnly Property ClientID As String
public:
virtual property String^ ClientID {
    String^ get () override;
}
Value
Return Value
The server control identifier generated by ASP.NET.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Controls Property

Controls Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► Controls
Barcode Framework Version: v2.0.3.0
Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Declaration Syntax
C# Visual Basic Visual C++
public override ControlCollection Controls { get; }
Public Overrides ReadOnly Property Controls As ControlCollection
public:
virtual property ControlCollection^ Controls {
    ControlCollection^ get () override;
}
Value
Return Value
The collection of child controls for the specified server control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


CreateControlCollection Method

CreateControlCollection Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► CreateControlCollection()()()
Barcode Framework Version: v2.0.3.0
Creates a new EmptyControlCollection object.
Declaration Syntax
C# Visual Basic Visual C++
protected override ControlCollection CreateControlCollection()
Protected Overrides Function CreateControlCollection As ControlCollection
protected:
virtual ControlCollection^ CreateControlCollection() override
Return Value
Always returns an EmptyControlCollection.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


DocumentContent Property

DocumentContent Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► DocumentContent
Barcode Framework Version: v2.0.3.0
Gets/sets a string that contains the XML document to display in the BarcodeXml control.
Declaration Syntax
C# Visual Basic Visual C++
public string DocumentContent { get; set; }
Public Property DocumentContent As String
public:
property String^ DocumentContent {
    String^ get ();
    void set (String^ value);
}
Return Value
A string that contains the XML document to display in the BarcodeXml control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


DocumentSource Property

DocumentSource Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► DocumentSource
Barcode Framework Version: v2.0.3.0
Gets or sets the path to an XML document to display in the BarcodeXml control.
Declaration Syntax
C# Visual Basic Visual C++
public string DocumentSource { get; set; }
Public Property DocumentSource As String
public:
property String^ DocumentSource {
    String^ get ();
    void set (String^ value);
}
Return Value
The path to an XML document to display in the BarcodeXml control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


EnableTheming Property

EnableTheming Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► EnableTheming
Barcode Framework Version: v2.0.3.0
Overrides the EnableTheming property. This property is not supported by the BarcodeXml class.
Declaration Syntax
C# Visual Basic Visual C++
public override bool EnableTheming { get; set; }
Public Overrides Property EnableTheming As Boolean
public:
virtual property bool EnableTheming {
    bool get () override;
    void set (bool value) override;
}
Return Value
Always returns false. This property is not supported.
Exceptions
Exception | Condition
NotSupportedException | An attempt is made to set the value of this property.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


FindControl Method (id)

FindControl Method (id)
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► FindControl(String)
Barcode Framework Version: v2.0.3.0
Searches the page naming container for the specified server control.
Declaration Syntax
C# Visual Basic Visual C++
public override Control FindControl(
    string id
)
Public Overrides Function FindControl ( _
    id As String _
) As Control
public:
virtual Control^ FindControl(
    String^ id
) override
Parameters
id (String)
The identifier for the control to be found.
Return Value
The specified control, or null if the specified control does not exist.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Focus Method

Focus Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► Focus()()()
Barcode Framework Version: v2.0.3.0
Overrides the Focus()()() method. This method is not supported by the BarcodeXml class.
Declaration Syntax
C# Visual Basic Visual C++
public override void Focus()
Public Overrides Sub Focus
public:
virtual void Focus() override
Exceptions
Exception | Condition
NotSupportedException | An attempt is made to invoke this method.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetDesignModeState Method

GetDesignModeState Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► GetDesignModeState()()()
Barcode Framework Version: v2.0.3.0
Gets design-time data for a control.
Declaration Syntax
C# Visual Basic Visual C++
protected override IDictionary GetDesignModeState()
Protected Overrides Function GetDesignModeState As IDictionary
protected:
virtual IDictionary^ GetDesignModeState() override
Return Value
An IDictionary containing the design-time data for the BarcodeXml control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


HasControls Method

HasControls Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► HasControls()()()
Barcode Framework Version: v2.0.3.0
Determines whether the server control contains any child controls.
Declaration Syntax
C# Visual Basic Visual C++
public override bool HasControls()
Public Overrides Function HasControls As Boolean
public:
virtual bool HasControls() override
Return Value
true if the control contains other controls; otherwise, false.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


RegisterExtensionObject Method (namespaceUri, extension)

RegisterExtensionObject Method (namespaceUri, extension)
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► RegisterExtensionObject(String, Object)
Barcode Framework Version: v2.0.3.0
Registers the specified extension object under the given namespace allowing methods on the object to be called by XSLT style-sheets.
Declaration Syntax
C# Visual Basic Visual C++
public void RegisterExtensionObject(
    string namespaceUri,
    Object extension
)
Public Sub RegisterExtensionObject ( _
    namespaceUri As String, _
    extension As Object _
)
public:
void RegisterExtensionObject(
    String^ namespaceUri,
    Object^ extension
)
Parameters
namespaceUri (String)
A String containing the namespace.
extension (Object)
An extension object.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Render Method (output)

Render Method (output)
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► Render(HtmlTextWriter)
Barcode Framework Version: v2.0.3.0
Renders the results to the output stream.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render ( _
    output As HtmlTextWriter _
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
Parameters
output (HtmlTextWriter)

[Missing <param name="output"/> documentation for "M:Zen.Barcode.Web.BarcodeXml.Render(System.Web.UI.HtmlTextWriter)"]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


SkinID Property

SkinID Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► SkinID
Barcode Framework Version: v2.0.3.0
Overrides the SkinID property. This property is not supported by the BarcodeXml class.
Declaration Syntax
C# Visual Basic Visual C++
public override string SkinID { get; set; }
Public Overrides Property SkinID As String
public:
virtual property String^ SkinID {
    String^ get () override;
    void set (String^ value) override;
}
Return Value
Always returns an empty string (""). This property is not supported.
Exceptions
Exception | Condition
NotSupportedException | An attempt is made to set the value of this property.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Transform Property

Transform Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► Transform
Barcode Framework Version: v2.0.3.0
Gets or sets the XslTransform object that formats the XML document before it is written to the output stream.
Declaration Syntax
C# Visual Basic Visual C++
public XslCompiledTransform Transform { get; set; }
Public Property Transform As XslCompiledTransform
public:
property XslCompiledTransform^ Transform {
    XslCompiledTransform^ get ();
    void set (XslCompiledTransform^ value);
}
Return Value
The XslTransform that formats the XML document before it is written to the output stream.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


TransformArgumentList Property

TransformArgumentList Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► TransformArgumentList
Barcode Framework Version: v2.0.3.0
Gets or sets a XsltArgumentList that contains a list of optional arguments passed to the style sheet and used during the Extensible Stylesheet Language Transformation (XSLT).
Declaration Syntax
C# Visual Basic Visual C++
public XsltArgumentList TransformArgumentList { get; set; }
Public Property TransformArgumentList As XsltArgumentList
public:
property XsltArgumentList^ TransformArgumentList {
    XsltArgumentList^ get ();
    void set (XsltArgumentList^ value);
}
Return Value
A XsltArgumentList that contains a list of optional arguments passed to the style sheet and used during the XSL Transformation.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


TransformSource Property

TransformSource Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► TransformSource
Barcode Framework Version: v2.0.3.0
Gets or sets the path to an Extensible Stylesheet Language Transformation (XSLT) style sheet that formats the XML document before it is written to the output stream.
Declaration Syntax
C# Visual Basic Visual C++
public string TransformSource { get; set; }
Public Property TransformSource As String
public:
property String^ TransformSource {
    String^ get ();
    void set (String^ value);
}
Return Value
The path to an XSL Transformation style sheet that formats the XML document before it is written to the output stream.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


XPathNavigator Property

XPathNavigator Property
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► XPathNavigator
Barcode Framework Version: v2.0.3.0
Gets or sets a cursor model for navigating and editing the XML data associated with the BarcodeXml control.
Declaration Syntax
C# Visual Basic Visual C++
public XPathNavigator XPathNavigator { get; set; }
Public Property XPathNavigator As XPathNavigator
public:
property XPathNavigator^ XPathNavigator {
    XPathNavigator^ get ();
    void set (XPathNavigator^ value);
}
Return Value
An XPathNavigator object.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Zen.Barcode.Web.Design Namespace

Zen.Barcode.Web.Design Namespace
Namespaces ► Zen.Barcode.Web.Design
Barcode Framework Version: v2.0.3.0
Contains design-time components to aid the use of barcode components from visual design tools such as the Visual Studio IDE.
Declaration Syntax
C# Visual Basic Visual C++
namespace Zen.Barcode.Web.Design
Namespace Zen.Barcode.Web.Design
namespace Zen.Barcode.Web.Design
Types
All Types Classes
Icon | Type | Description
 | BarcodeXmlDesigner | Extends design-time behavior for the BarcodeXml Web server control.


BarcodeXmlDesigner Class

BarcodeXmlDesigner Class
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner
Barcode Framework Version: v2.0.3.0
Extends design-time behavior for the BarcodeXml Web server control.
Declaration Syntax
C# Visual Basic Visual C++
public class BarcodeXmlDesigner : ControlDesigner
Public Class BarcodeXmlDesigner _
    Inherits ControlDesigner
public ref class BarcodeXmlDesigner : public ControlDesigner
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarcodeXmlDesigner()()() | Initialises a new instance of the BarcodeXmlDesigner class.
 | ActionLists | Gets the action list collection for the control designer. (Inherited from ControlDesigner.)
 | AllowResize | Gets a value indicating whether the control can be resized in the design-time environment. (Inherited from ControlDesigner.)
 | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ComponentDesigner.)
 | AutoFormats | Gets the collection of predefined automatic formatting schemes to display in the Auto Format dialog box for the associated control at design time. (Inherited from ControlDesigner.)
 | Behavior | Obsolete. Gets or sets the DHTML behavior that is associated with the designer. (Inherited from HtmlControlDesigner.)
 | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
 | CreateErrorDesignTimeHtml(String) | Creates HTML markup to display a specified error message at design time. (Inherited from ControlDesigner.)
 | CreateErrorDesignTimeHtml(String, Exception) | Creates the HTML markup to display a specified exception error message at design time. (Inherited from ControlDesigner.)
 | CreatePlaceHolderDesignTimeHtml()()() | Provides a simple rectangular placeholder representation that displays the type and ID of the control. (Inherited from ControlDesigner.)
 | CreatePlaceHolderDesignTimeHtml(String) | Provides a simple rectangular placeholder representation that displays the type and ID of the control, and also additional specified instructions or information. (Inherited from ControlDesigner.)
 | CreateViewControl()()() | Returns a copy of the associated control for viewing or rendering on the design surface. (Inherited from ControlDesigner.)
 | DataBindings | Gets the data bindings collection for the current control. (Inherited from HtmlControlDesigner.)
 | DataBindingsEnabled | Gets a value indicating whether data binding is supported by the containing region for the associated control. (Inherited from ControlDesigner.)
 | DesignerState | Gets an object that is used to persist data for the associated control at design time. (Inherited from ControlDesigner.)
 | DesignTimeElement | Obsolete. Gets the design-time object representing the control that is associated with the HtmlControlDesigner object on the design surface. (Inherited from HtmlControlDesigner.)
 | DesignTimeElementView | Obsolete. Gets the view-control object for the control designer. (Inherited from ControlDesigner.)
 | DesignTimeHtmlRequiresLoadComplete | Obsolete. Gets a value indicating whether the design host must finish loading before the GetDesignTimeHtml()()() method can be called. (Inherited from ControlDesigner.)
 | Dispose(Boolean) | Releases the unmanaged resources that are used by the BarcodeXmlDesigner control and optionally releases the managed resources. (Overrides HtmlControlDesigner.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
 | DoDefaultAction()()() | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expressions | Gets the expression bindings for the current control at design time. (Inherited from HtmlControlDesigner.)
 | Finalize()()() | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
 | GetBounds()()() | Retrieves the coordinates of the rectangle representing the boundaries for the control as displayed on the design surface. (Inherited from ControlDesigner.)
 | GetDesignTimeHtml()()() | Retrieves the HTML markup that is used to represent the control at design time. (Overrides ControlDesigner.GetDesignTimeHtml()()().)
 | GetDesignTimeHtml(DesignerRegionCollection) | Retrieves the HTML markup to display the control and populates the collection with the current control designer regions. (Inherited from ControlDesigner.)
 | GetEditableDesignerRegionContent(EditableDesignerRegion) | Returns the content for an editable region of the design-time view of the associated control. (Inherited from ControlDesigner.)
 | GetEmptyDesignTimeHtml()()() | Gets the HTML that is used to fill an empty control. (Overrides ControlDesigner.GetEmptyDesignTimeHtml()()().)
 | GetErrorDesignTimeHtml(Exception) | Retrieves the HTML markup that provides information about the specified exception. (Inherited from ControlDesigner.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPersistenceContent()()() | Retrieves the persistable inner HTML markup of the control at design time. (Inherited from ControlDesigner.)
 | GetPersistInnerHtml()()() | Obsolete. Retrieves the persistable inner HTML markup of the control. (Overrides ControlDesigner.GetPersistInnerHtml()()().)
 | GetService(Type) | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewRendering()()() | Retrieves an object that contains the design-time markup for the content and regions of the associated control. (Inherited from ControlDesigner.)
 | HidePropertiesInTemplateMode | Gets a value indicating whether the properties of the associated control are hidden when the control is in template mode. (Inherited from ControlDesigner.)
 | ID | Gets or sets the ID string for the control. (Inherited from ControlDesigner.)
 | InheritanceAttribute | Gets an attribute that indicates the type of inheritance of the associated component. (Inherited from ComponentDesigner.)
 | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
 | Initialize(IComponent) | Initializes the designer with the control that this instance of the designer is associated with. (Overrides ControlDesigner.Initialize(IComponent).)
 | InitializeExistingComponent(IDictionary) | Reinitializes an existing component. (Inherited from ComponentDesigner.)
 | InitializeNewComponent(IDictionary) | Initializes a newly created component. (Inherited from ComponentDesigner.)
 | InitializeNonDefault()()() | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
 | InTemplateMode | Gets a value indicating whether the control is in either template viewing or editing mode in the design host. The InTemplateMode property is read-only. (Inherited from ControlDesigner.)
 | Invalidate()()() | Invalidates the whole area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
 | Invalidate(Rectangle) | Invalidates the specified area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
 | InvokeGetInheritanceAttribute(ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
 | IsDirty | Obsolete. Gets or sets a value indicating whether the Web server control has been marked as changed. (Inherited from ControlDesigner.)
 | IsPropertyBound(String) | Obsolete. Retrieves a value indicating whether the specified property on the associated control is data-bound. (Inherited from ControlDesigner.)
 | Localize(IDesignTimeResourceWriter) | Uses the provided resource writer to persist the localizable properties of the associated control to a resource in the design host. (Inherited from ControlDesigner.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnAutoFormatApplied(DesignerAutoFormat) | Called when a predefined, automatic formatting scheme has been applied to the associated control. (Inherited from ControlDesigner.)
 | OnBehaviorAttached()()() | Obsolete. Called when a behavior is associated with the element. (Inherited from HtmlControlDesigner.)
 | OnBehaviorDetaching()()() | Obsolete. Called when a behavior disassociates from the element. (Inherited from HtmlControlDesigner.)
 | OnBindingsCollectionChanged(String) | Obsolete. Called when the data-binding collection changes. (Inherited from ControlDesigner.)
 | OnClick(DesignerRegionMouseEventArgs) | Called by the design host when the user clicks the associated control at design time. (Inherited from ControlDesigner.)
 | OnComponentChanged(Object, ComponentChangedEventArgs) | Called when the associated control changes. (Inherited from ControlDesigner.)
 | OnComponentChanging(Object, ComponentChangingEventArgs) | Represents the method that will handle the ComponentChanging event for the associated control. (Inherited from ControlDesigner.)
 | OnControlResize()()() | Obsolete. Called when the associated Web server control has been resized in the design host at design time. (Inherited from ControlDesigner.)
 | OnPaint(PaintEventArgs) | Called when the control designer draws the associated control on the design surface, if the CustomPaint value is true. (Inherited from ControlDesigner.)
 | OnSetComponentDefaults()()() | Obsolete. Sets the default properties for the component. (Inherited from ComponentDesigner.)
 | OnSetParent()()() | Provides a way to perform additional processing when the associated control is attached to a parent control. (Inherited from HtmlControlDesigner.)
 | ParentComponent | Gets the parent component for this designer. (Inherited from ComponentDesigner.)
 | PostFilterAttributes(IDictionary) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
 | PostFilterEvents(IDictionary) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
 | PostFilterProperties(IDictionary) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
 | PreFilterAttributes(IDictionary) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
 | PreFilterEvents(IDictionary) | Sets the list of events that are exposed at design-time for the TypeDescriptor object for the component. (Inherited from HtmlControlDesigner.)
 | PreFilterProperties(IDictionary) | Adds properties to or removes properties from the Properties grid in a design host at design time or provides new design-time properties that might correspond to properties on the associated control. (Inherited from ControlDesigner.)
 | RaiseComponentChanged(MemberDescriptor, Object, Object) | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
 | RaiseComponentChanging(MemberDescriptor) | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
 | RaiseResizeEvent()()() | Obsolete. Raises the OnControlResize()()() event. (Inherited from ControlDesigner.)
 | ReadOnly | Obsolete. Gets or sets a value indicating whether the properties of the control are read-only at design time. (Inherited from ControlDesigner.)
 | RegisterClone(Object, Object) | Registers internal data in a cloned control. (Inherited from ControlDesigner.)
 | RootDesigner | Gets the control designer for the Web Forms page that contains the associated control. (Inherited from ControlDesigner.)
 | SetEditableDesignerRegionContent(EditableDesignerRegion, String) | Specifies the content for an editable region of the control at design time. (Inherited from ControlDesigner.)
 | SetRegionContent(EditableDesignerRegion, String) | Specifies the content for an editable region in the design-time view of the control. (Inherited from ControlDesigner.)
 | SetViewFlags(ViewFlags, Boolean) | Assigns the specified bitwise ViewFlags enumeration to the specified flag value. (Inherited from ControlDesigner.)
 | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
 | ShouldCodeSerialize | Obsolete. Gets or sets a value indicating whether to create a field declaration for the control in the code-behind file for the current design document during serialization. (Inherited from HtmlControlDesigner.)
 | Tag | Gets an object representing the HTML markup element for the associated control. (Inherited from ControlDesigner.)
 | TemplateGroups | Gets a collection of template groups, each containing one or more template definitions. (Inherited from ControlDesigner.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateDesignTimeHtml()()() | Refreshes the design-time HTML markup for the associated Web server control by calling the GetDesignTimeHtml()()() method. (Inherited from ControlDesigner.)
 | UsePreviewControl | Gets a value indicating whether the control designer uses a temporary preview control to generate the design-time HTML markup. (Inherited from ControlDesigner.)
 | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
 | ViewControl | Gets or sets a Web server control that can be used for previewing the design-time HTML markup. (Inherited from ControlDesigner.)
 | ViewControlCreated | Gets or sets a value indicating whether a View control has been created for display on the design surface. (Inherited from ControlDesigner.)
 | Visible | Gets a value that indicates whether the control is visible at design time. (Inherited from ControlDesigner.)
Inheritance Hierarchy
Object
 | ComponentDesigner
 |  | HtmlControlDesigner
 |  |  | ControlDesigner
 |  |  |  | BarcodeXmlDesigner

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


BarcodeXmlDesigner Constructor

BarcodeXmlDesigner Constructor
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► BarcodeXmlDesigner()()()
Barcode Framework Version: v2.0.3.0
Initialises a new instance of the BarcodeXmlDesigner class.
Declaration Syntax
C# Visual Basic Visual C++
public BarcodeXmlDesigner()
Public Sub New
public:
BarcodeXmlDesigner()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► Dispose(Boolean)
Barcode Framework Version: v2.0.3.0
Releases the unmanaged resources that are used by the BarcodeXmlDesigner control and optionally releases the managed resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true to release both managed and unmanaged resources; false to release only unmanaged resources.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetDesignTimeHtml Method

GetDesignTimeHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► GetDesignTimeHtml()()()
Barcode Framework Version: v2.0.3.0
Retrieves the HTML markup that is used to represent the control at design time.
Declaration Syntax
C# Visual Basic Visual C++
public override string GetDesignTimeHtml()
Public Overrides Function GetDesignTimeHtml As String
public:
virtual String^ GetDesignTimeHtml() override
Return Value
The HTML markup used to represent the control at design time.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetEmptyDesignTimeHtml Method

GetEmptyDesignTimeHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► GetEmptyDesignTimeHtml()()()
Barcode Framework Version: v2.0.3.0
Gets the HTML that is used to fill an empty control.
Declaration Syntax
C# Visual Basic Visual C++
protected override string GetEmptyDesignTimeHtml()
Protected Overrides Function GetEmptyDesignTimeHtml As String
protected:
virtual String^ GetEmptyDesignTimeHtml() override
Return Value
The HTML used to fill an empty control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetPersistInnerHtml Method

GetPersistInnerHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► GetPersistInnerHtml()()()
Barcode Framework Version: v2.0.3.0
Retrieves the persistable inner HTML markup of the control.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute]
public override string GetPersistInnerHtml()
<ObsoleteAttribute> _
Public Overrides Function GetPersistInnerHtml As String
[ObsoleteAttribute]
public:
virtual String^ GetPersistInnerHtml() override
Return Value
The persistable inner HTML markup of the control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


Initialize Method (component)

Initialize Method (component)
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► Initialize(IComponent)
Barcode Framework Version: v2.0.3.0
Initializes the designer with the control that this instance of the designer is associated with.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize(
    IComponent component
)
Public Overrides Sub Initialize ( _
    component As IComponent _
)
public:
virtual void Initialize(
    IComponent^ component
) override
Parameters
component (IComponent)
The associated control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


Zen.Barcode.Web.Xsl Namespace

Zen.Barcode.Web.Xsl Namespace
Namespaces ► Zen.Barcode.Web.Xsl
Barcode Framework Version: v2.0.3.0
Contains barcode-to-XSL bridge components.
Declaration Syntax
C# Visual Basic Visual C++
namespace Zen.Barcode.Web.Xsl
Namespace Zen.Barcode.Web.Xsl
namespace Zen.Barcode.Web.Xsl
Types
All Types Classes
Icon | Type | Description
 | XsltBarcodeExtension | XsltBarcodeExtension provides a handful of custom functions that are callable from XSLT style-sheets and allow barcode URIs to be encoded in an XSLT style-sheet output.


XsltBarcodeExtension Class

XsltBarcodeExtension Class
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension
Barcode Framework Version: v2.0.3.0
XsltBarcodeExtension provides a handful of custom functions that are callable from XSLT style-sheets and allow barcode URIs to be encoded in an XSLT style-sheet output.
Declaration Syntax
C# Visual Basic Visual C++
public class XsltBarcodeExtension
Public Class XsltBarcodeExtension
public ref class XsltBarcodeExtension
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XsltBarcodeExtension()()() | Initializes a new instance of the XsltBarcodeExtension class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarcode11C(String) | Gets the barcode image URI for the specified text using the Code 11 barcode symbology with checksum.
 | GetBarcode11NC(String) | Gets the barcode image URI for the specified text using the Code 11 barcode symbology without checksum.
 | GetBarcode128(String) | Gets the barcode image URI for the specified text using the Code 128 barcode symbology.
 | GetBarcode39C(String) | Gets the barcode image URI for the specified text using the Code 39 barcode symbology with checksum.
 | GetBarcode39NC(String) | Gets the barcode image URI for the specified text using the Code 39 barcode symbology without checksum.
 | GetBarcode93(String) | Gets the barcode image URI for the specified text using the Code 93 barcode symbology.
 | GetBarcodeEan13(String) | Gets the barcode image URI for the specified text using the Code EAN-13 barcode symbology.
 | GetBarcodeEan8(String) | Gets the barcode image URI for the specified text using the Code EAN-8 barcode symbology.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

The use of this class enables XSLT style-sheet authors to substitute barcode text for the associated image URI directly in the style-sheet.

To use this extension it is necessary to ensure that the object is registered via an XsltArgumentList and passed to the XslTransform class.

Extension namespace: http://schemas.siamzen.com/barcodes

Examples
XsltArgumentList list = new XsltArgumentList (); list.AddExtensionObject ("http://schemas.siamzen.com/barcodes", new XsltBarcodeExtension ());
Inheritance Hierarchy
Object
XsltBarcodeExtension

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


XsltBarcodeExtension Constructor

XsltBarcodeExtension Constructor
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► XsltBarcodeExtension()()()
Barcode Framework Version: v2.0.3.0
Initializes a new instance of the XsltBarcodeExtension class
Declaration Syntax
C# Visual Basic Visual C++
public XsltBarcodeExtension()
Public Sub New
public:
XsltBarcodeExtension()

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode11C Method (text)

GetBarcode11C Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode11C(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 11 barcode symbology with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode11C(
    string text
)
Public Function GetBarcode11C ( _
    text As String _
) As String
public:
String^ GetBarcode11C(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode11C(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode11C(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode11NC Method (text)

GetBarcode11NC Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode11NC(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 11 barcode symbology without checksum.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode11NC(
    string text
)
Public Function GetBarcode11NC ( _
    text As String _
) As String
public:
String^ GetBarcode11NC(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode11NC(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode11NC(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode128 Method (text)

GetBarcode128 Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode128(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 128 barcode symbology.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode128(
    string text
)
Public Function GetBarcode128 ( _
    text As String _
) As String
public:
String^ GetBarcode128(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode128(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode128(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode39C Method (text)

GetBarcode39C Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode39C(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 39 barcode symbology with checksum.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode39C(
    string text
)
Public Function GetBarcode39C ( _
    text As String _
) As String
public:
String^ GetBarcode39C(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode39C(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode39C(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode39NC Method (text)

GetBarcode39NC Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode39NC(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 39 barcode symbology without checksum.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode39NC(
    string text
)
Public Function GetBarcode39NC ( _
    text As String _
) As String
public:
String^ GetBarcode39NC(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode39NC(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode39NC(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcode93 Method (text)

GetBarcode93 Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcode93(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code 93 barcode symbology.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcode93(
    string text
)
Public Function GetBarcode93 ( _
    text As String _
) As String
public:
String^ GetBarcode93(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode93(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcode93(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcodeEan13 Method (text)

GetBarcodeEan13 Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcodeEan13(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code EAN-13 barcode symbology.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcodeEan13(
    string text
)
Public Function GetBarcodeEan13 ( _
    text As String _
) As String
public:
String^ GetBarcodeEan13(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcodeEan13(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcodeEan13(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetBarcodeEan8 Method (text)

GetBarcodeEan8 Method (text)
Namespaces ► Zen.Barcode.Web.Xsl ► XsltBarcodeExtension ► GetBarcodeEan8(String)
Barcode Framework Version: v2.0.3.0
Gets the barcode image URI for the specified text using the Code EAN-8 barcode symbology.
Declaration Syntax
C# Visual Basic Visual C++
public string GetBarcodeEan8(
    string text
)
Public Function GetBarcodeEan8 ( _
    text As String _
) As String
public:
String^ GetBarcodeEan8(
    String^ text
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcodeEan8(System.String)"]

Return Value

[Missing <returns> documentation for M:Zen.Barcode.Web.Xsl.XsltBarcodeExtension.GetBarcodeEan8(System.String)]

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


FindControl Method

FindControl Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► FindControl()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for the specified server control. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetDesignTimeHtml Method

GetDesignTimeHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► GetDesignTimeHtml()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetDesignTimeHtml()()() | Retrieves the HTML markup that is used to represent the control at design time. (Overrides ControlDesigner.GetDesignTimeHtml()()().)
 | GetDesignTimeHtml(DesignerRegionCollection) | Retrieves the HTML markup to display the control and populates the collection with the current control designer regions.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


RenderControl Method

RenderControl Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► RenderControl()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Invalidate Method

Invalidate Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► Invalidate()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Invalidate()()() | Invalidates the whole area of the control that is displayed on the design surface and signals the control designer to redraw the control.
 | Invalidate(Rectangle) | Invalidates the specified area of the control that is displayed on the design surface and signals the control designer to redraw the control.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


Dispose Method

Dispose Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► Dispose()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Dispose(Boolean) | Releases the unmanaged resources that are used by the BarcodeXmlDesigner control and optionally releases the managed resources. (Overrides HtmlControlDesigner.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the ComponentDesigner.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code25StandardGlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code25InterleavedGlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code25InterleavedGlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Code39Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String).)
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► BinaryPitchVaryLengthBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code25GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code25StandardGlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code93GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs()()() | Overridden. Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology. (Overrides GlyphFactory.GetGlyphs()()().)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► CodeEan8Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► CodeEan8GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


RenderControl Method

RenderControl Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► RenderControl()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code128GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► Code128BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► CodeEan13GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► CodeEan13Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► Code25BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► CodeEan13GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


CreatePlaceHolderDesignTimeHtml Method

CreatePlaceHolderDesignTimeHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► CreatePlaceHolderDesignTimeHtml()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | CreatePlaceHolderDesignTimeHtml()()() | Provides a simple rectangular placeholder representation that displays the type and ID of the control.
 | CreatePlaceHolderDesignTimeHtml(String) | Provides a simple rectangular placeholder representation that displays the type and ID of the control, and also additional specified instructions or information.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► CodeEan8GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string. (Overrides GlyphFactory.GetGlyphs(String, Boolean).)
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


FindControl Method

FindControl Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► FindControl()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code11GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► Code39BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► FactoryChecksum<(Of <(T>)>) ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string.


CreateErrorDesignTimeHtml Method

CreateErrorDesignTimeHtml Method
Namespaces ► Zen.Barcode.Web.Design ► BarcodeXmlDesigner ► CreateErrorDesignTimeHtml()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | CreateErrorDesignTimeHtml(String) | Creates HTML markup to display a specified error message at design time.
 | CreateErrorDesignTimeHtml(String, Exception) | Creates the HTML markup to display a specified exception error message at design time.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Design (Module: Zen.Barcode.Design) Version: 2.0.3.0 (2.0.3.0)


GetGlyphs Method

GetGlyphs Method
Namespaces ► Zen.Barcode ► Code39GlyphFactory ► GetGlyphs()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetGlyphs(Char) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(Char, Boolean) | Gets the array of Glyph objects that correspond to the specified character.
 | GetGlyphs(String) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs(String, Boolean) | Gets the array of Glyph objects that correspond to the specified string.
 | GetGlyphs()()() | Gets the collection of BarGlyph that represent the raw bar-code glyphs for the given bar-code symbology.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code39GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


DataBind Method

DataBind Method
Namespaces ► Zen.Barcode.Web ► BarcodeLabel ► DataBind()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | DataBind()()() | Binds a data source to the CompositeControl and all its child controls. (Overrides Control.DataBind()()().)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► CodeEan8BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


DataBind Method

DataBind Method
Namespaces ► Zen.Barcode.Web ► BarcodeXml ► DataBind()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

© Zen Design 2006 - 2008

Assembly: Zen.Barcode.Web (Module: Zen.Barcode.Web) Version: 2.0.3.0 (2.0.3.0)


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Code128Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► CodeEan13BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code93GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


Namespaces

Namespaces
Namespaces
Barcode Framework Version: v2.0.3.0

Zen Barcode Rendering Framework

The barcode framework started life as a royalty-free method of embedding barcodes into a web-site project without having to use custom fonts and has since developed into a full-blown barcode rendering suite.

The framework supports Windows Forms applications as well as ASP.NET - the ASP.NET component can also be leveraged by an XSLT namespace extension to provide barcode rendering capabilities to XSLT stylesheets - this feature can be used to generate HTML reports from SQL XML resultset information!

The framework is being actively developed into a single royalty-free class library for Microsoft (r) .NET Framework with the aim to provide support for all 2D barcode symbologies. Ultimately even 3D barcodes will be supported although that will mean I need to buy another scanner...

Currently the project is located on the CodePlex web-site so if you have any comments and suggestions please feel free to leave them there!

Enjoy the framework
The Barcode Rendering Framework Team

Namespaces
Namespace | Description
Zen.Barcode | Contains all core barcode rendering classes.
Zen.Barcode.Web | Contains all ASP.NET barcode support objects.
Zen.Barcode.Web.Design | Contains design-time components to aid the use of barcode components from visual design tools such as the Visual Studio IDE.
Zen.Barcode.Web.Xsl | Contains barcode-to-XSL bridge components.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► BinaryPitchBarcodeDraw<(Of <(TGlyphFactory, TChecksum>)>) ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► Code11BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Code11Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.


Draw Method

Draw Method
Namespaces ► Zen.Barcode ► Code93BarcodeDraw ► Draw()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | Draw(String, Int32, Int32) | Overridden. Draws a fixed-pitch barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32) | Overridden. Draws a variable-pitched barcode for the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32).)
 | Draw(String, Int32, Int32, Int32, Int32, Int32) | Overridden. Draws the specified text. (Overrides BarcodeDraw.Draw(String, Int32, Int32, Int32, Int32, Int32).)
 | Draw(String, BarcodeMetrics) | Draws the specified text using the supplied barcode metrics.
 | Draw(String, Int32) | Draws the specified text using the default barcode metrics for the specified maximum barcode height.


GetRawGlyph Method

GetRawGlyph Method
Namespaces ► Zen.Barcode ► Code11GlyphFactory ► GetRawGlyph()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetRawGlyph(Int32) | Gets the BarGlyph at the specified ordinal index.
 | GetRawGlyph(Char) | Gets the BarGlyph that corresponds to the specified character.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Code93Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String).)
 | GetChecksum(String, Boolean) | Gets an array of Glyph objects that represent the checksum for the specified text string.


GetChecksum Method

GetChecksum Method
Namespaces ► Zen.Barcode ► Code25Checksum ► GetChecksum()()()
Barcode Framework Version: v2.0.3.0
Members
Icon | Member | Description
 | GetChecksum(String, Boolean) | Overridden. Gets an array of Glyph objects that represent the checksum for the specified text string. (Overrides Checksum.GetChecksum(String, Boolean).)
 | GetChecksum(String) | Gets an array of Glyph objects that represent the checksum for the specified text string.